Skip to content
Permalink
Browse files

adding gstreamer-vaapi

set to python3, needs to be done for all gstreamer
samba 4.10.1
exfat-utils don't set sbin
  • Loading branch information...
demmm committed Apr 3, 2019
1 parent ff69b9f commit e360c32990ed68aa63ac63ce927329f57351c1eb
Showing with 40 additions and 4 deletions.
  1. +0 −1 exfat-utils/PKGBUILD
  2. +37 −0 gstreamer-vaapi/PKGBUILD
  3. +3 −3 samba/PKGBUILD
@@ -14,7 +14,6 @@ build() {
cd ${pkgname}-${pkgver}

./configure --prefix=/usr \
--sbindir=/usr/bin
make
}

@@ -0,0 +1,37 @@

pkgname=gstreamer-vaapi
pkgver=1.14.4
pkgrel=1
pkgdesc="GStreamer Multimedia Framework Vaapi Plugin"
arch=('x86_64')
license=('LGPL')
url="https://gstreamer.freedesktop.org/"
depends=('gst-plugins-bad' 'libva' 'libxrandr')
makedepends=('python3' 'gobject-introspection')
options=('!libtool')
source=("https://gstreamer.freedesktop.org/src/gstreamer-vaapi/${pkgname}-${pkgver}.tar.xz")
sha256sums=('ce18dbfe961c6a8d31270231686075586bf7a7df62b778c8e7f5ec148251d0a3')

build() {
cd ${pkgname}-${pkgver}

./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--libexecdir=/usr/lib \
--disable-static \
PYTHON=/usr/bin/python3
make
}

check() {
cd ${pkgname}-${pkgver}

make check
}

package() {
cd ${pkgname}-${pkgver}

make DESTDIR=${pkgdir} install
}
@@ -1,8 +1,8 @@

# check tdb & ldb for updates before building, use libxml2 2.9.4/libxslt 1.1.29 or older
pkgname=samba
pkgver=4.10.0
_pkgver=4.10.0
pkgver=4.10.1
_pkgver=4.10.1
pkgrel=1
arch=('x86_64')
pkgdesc="The standard Windows interoperability suite of programs for Linux and Unix."
@@ -23,7 +23,7 @@ source=("https://us1.samba.org/samba/ftp/stable/${pkgname}-${_pkgver}.tar.gz"
'samba.pam'
'samba.conf'
'samba.conf.d')
md5sums=('d6ed560c9f0b70b287e9eaf2f378697a'
md5sums=('e20678bebd7cf625dc2c9f53101366fe'
'995621522c6ec9b68c1b858ceed627ed'
'96f82c38f3f540b53f3e5144900acf17'
'49abd7b719e3713a3f75a8a50958e381'

0 comments on commit e360c32

Please sign in to comment.
You can’t perform that action at this time.