Interfacing Qt/QML with OCaml. Formely known as lablqt
OCaml C C++ Makefile QML
Latest commit b549e3c Aug 8, 2017 @Kakadu Kakadu update verion in files
Permalink
Failed to load latest commit information.
demos Fix compilation of demos Aug 8, 2017
lib update verion in files Aug 8, 2017
ppx Run Driver.main Aug 2, 2017
.gitignore List converting fixed Jun 15, 2014
CHANGELOG update change log Aug 8, 2017
CONTRIBUTING.md Add contributing.md Aug 8, 2017
Makefile.install Add forgotten file Feb 24, 2017
README.md #56: mentioning reason Aug 6, 2017
configure renamed lablqml dir to lib Feb 23, 2017
opam

README.md

Let's write QML/QtQuick GUI for OCaml (or Reason) using lablqml!

In this repo you can find my work about integrating OCaml and Qt. Initially, I planned to generate binding code for OCaml and Qt Widgets and called this library lablqt. But I found it hard to implement mostly because Qt relies on inheritance very much (we can't add onClick handler for button without inheritance). Later I decided to generate binding code for OCaml and QtQuick. And I believe that QtQuick is the right way to create UI in Qt right now.

From 14th of February 2017 it's renamed from lablqt to lablqml because it is actually about QtQuick and not QtWidgets or Qt itself. If you really need QtWidgets you can check out mrvn's work.

Directories mapping:

  • PPX syntax extension with code generator is in ppx/.
  • Library for interfacing with QtQuick 2 is in lablqml.
  • Demos are in demos/. Use ./configure && make test to build them.
  • Demo app qocamlbrowser (ocamlbrowser with QtQuick instead of Tcl/Tk) is located in separate repo.

Github pages site and tutorial are available.

Use ./configure && make to build it. Don't forget to install g++ and good Qt version (>= 5.3 I think, ./configure will check for it, btw).