Skip to content
A command line REPL extension for BoltCMS using PsySH.
PHP
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
config
src
templates
tests
web
.gitignore
README.md
VERSION
composer.json
phpunit.xml.dist

README.md

PsySH For oltCMS

A extension to use the php REPL PsySH with BoltCMS v3. Learn more at psysh.org.

What does it do exactly?

  • Loads PsySH with the application dependencies
  • Gives access to the following variables:
Variable Description
$app Instance of Pimple container

Install

Before using this extension, you must install psy/psysh package:

php composer install psy/psysh @stable

Then you can install extension:

php app/nut extensions:install kenny1911/bolt-psysh 1.0.0

Usage

php app/nut psysh
You can’t perform that action at this time.