Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Config editor issue #124

Closed
sepich opened this issue Sep 24, 2016 · 3 comments
Closed

Config editor issue #124

sepich opened this issue Sep 24, 2016 · 3 comments

Comments

@sepich
Copy link

@sepich sepich commented Sep 24, 2016

Installed Keypirinha to c:\Program Files (x86)\Portable\Keypirinha\keypirinha.exe and doing basic config:

[external]
editor = "c:\Program Files (x86)\Portable\Sublime\sublime_text.exe"
editor_accepts_multifiles = yes

Thus getting Sublime opened with 4 empty tabs:
screenshot

c:\Program
c:\Program Files (x86)\Portable\Keypirinha\Files
c:\Program Files (x86)\Portable\Keypirinha\(x86)\Portable\Keypirinha\portable\Profile\User\Keypirinha.ini
c:\Program Files (x86)\Portable\Keypirinha\(x86)\Portable\Keypirinha\default\App\Keypirinha.ini

Changing path to subl.exe leads to the same result.

@polyvertex
Copy link
Member

@polyvertex polyvertex commented Sep 24, 2016

Confirmed, Keypirinha does not quote the paths to the files to edit before launching the editor. Code has been corrected already and fix will be available in the next release. Sorry for the inconvenience.
EDIT: the bug does not affect the default configuration (i.e. when the bundled Notepad2 editor is used)

As a side note, installing KP under C:\Program Files in portable mode is not recommended as you may run into trouble due to the standard Windows policy of restricted write-access to this folder. As an alternative, you can either:

  • Run KP under C:\Program Files, in installed mode (see the installation procedure)
  • Move KP outside of the C:\Program Files folder if you wish to remain in portable mode
@polyvertex polyvertex changed the title Sublime as config editor issue Config editor issue Sep 24, 2016
@sepich
Copy link
Author

@sepich sepich commented Sep 24, 2016

Good to know that its already taken care of.
And thanks - i've read that note in the docs 😉

@polyvertex
Copy link
Member

@polyvertex polyvertex commented Sep 29, 2016

This should work as of v2.9.6

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.