High CPU usage after launching apps #146

Closed
ZIEXED opened this Issue Jan 10, 2017 · 3 comments

Comments

Projects
None yet
2 participants
@ZIEXED

ZIEXED commented Jan 10, 2017

After launching apps KP consume the whole thread power of my CPU (12.5%) for 3 seconds

@polyvertex

This comment has been minimized.

Show comment
Hide comment
@polyvertex

polyvertex Jan 10, 2017

Member

Yes this is due to the use of Windows' ShellExecuteEx function.
Once an item has been launched with that API, Keypirinha has to flush any COM message implied by this call. The timing you observe seems about right but I will investigate about the CPU usage.

Member

polyvertex commented Jan 10, 2017

Yes this is due to the use of Windows' ShellExecuteEx function.
Once an item has been launched with that API, Keypirinha has to flush any COM message implied by this call. The timing you observe seems about right but I will investigate about the CPU usage.

@polyvertex

This comment has been minimized.

Show comment
Hide comment
@polyvertex

polyvertex Jan 11, 2017

Member

Ah. Found the culprit. This will be corrected in the next release.

Member

polyvertex commented Jan 11, 2017

Ah. Found the culprit. This will be corrected in the next release.

@polyvertex

This comment has been minimized.

Show comment
Hide comment
@polyvertex

polyvertex Jan 14, 2017

Member

Fixed in v2.9.10

Member

polyvertex commented Jan 14, 2017

Fixed in v2.9.10

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment