Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Missing error for corrupted package #368

Closed
DrorHarari opened this issue Mar 8, 2019 · 2 comments

Comments

@DrorHarari
Copy link

commented Mar 8, 2019

I got complaints that my Ppl package was installed (as seen in the log) but was not available for use.

It took me some time but then I figured that due to a missing file, the creation of the .keypirinha-package file was interrupted so the package had an unexpected early end of file and that was the reason KP did not make it available.

The problem is that KP did not show any error for that - it should have, at least, write that the package was corrupted and didn't get loaded. Please see attached corrupted package (as was downloaded from PackageControl). Note - the .zip extension should be dropped.

Ppl.keypirinha-package.zip

@polyvertex

This comment has been minimized.

Copy link
Member

commented Aug 13, 2019

I just had a look at KP's source code and it does print something out when it could not read the Zip file properly. So I will have to test that with the file you shared - luckily you did.

@polyvertex

This comment has been minimized.

Copy link
Member

commented Aug 18, 2019

Modification done in release v2.24

@polyvertex polyvertex closed this Aug 18, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.