Skip to content
Development tool to measure, monitor and analyze the memory behavior of Python objects in a running Python application.
Python CSS
Find file
Pull request Compare This branch is 1 commit ahead, 49 commits behind pympler:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
doc/source
examples
pympler
test
tmp
tools
.coveragerc
.travis.yml
CHANGELOG
LICENSE
MANIFEST.in
NOTICE
README.md
developer-notes.txt
run.py
setup.py

README.md

README for pympler

Before installing Pympler, try it with your Python version:

python setup.py try

If any errors are reported, check whether your Python version is supported by all the Pympler modules. Pympler is written entirely in Python, with no dependencies other than standard Python modules and libraries. Pympler works with Python 2.5, 2.6, 2.7, 3.1, 3.2 and 3.3.

Installation

  1. Build the Pympler package:

    python setup.py build

2.a) For a system-wide installation run:

python setup.py install

2.b) For a user-specific** installation run:

python setup.py --user install

3) Test the installed Pympler package:

python setup.py test

**) Note, the user-specific installation requires Python 2.6 or higher.

Usage

The usage of pympler is described in the documentation. It is available either in this distribution at doc/index.html or you can read it online.

Contributing

You can post wishes, bug reports or patches at our issue tracker or write an email to pympler-dev@googlegroups.com.

Build status

Something went wrong with that request. Please try again.