Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Principled node now has alpha and emission inputs #462

Open
julienduroure opened this issue May 13, 2019 · 5 comments · May be fixed by #740

Comments

@julienduroure
Copy link
Collaborator

commented May 13, 2019

Cf https://developer.blender.org/rB8f71a84496a95528303fbe0bb7c1406060353425

We have to change importer and exporter to take into account this change (this will simply the node setup :) )

@SteffenDuenner

This comment has been minimized.

Copy link

commented May 13, 2019

Nice! I was just about to post this commit here :)

@donmccurdy

This comment has been minimized.

Copy link
Member

commented May 13, 2019

Wow, yes that potentially helps quite a lot. Do "Alpha Blend" and "Alpha Clip" modes still work as expected?

Was this on a roadmap we could have seen earlier? I'd asked in the dev forums a few months ago and it sounded like the answer was "maybe someday" at the time, might have saved some trouble if we'd known this. 😅

In any case, strong +1 for using the new inputs.

@julienduroure

This comment has been minimized.

Copy link
Collaborator Author

commented May 13, 2019

Was a surprise for me too ;-)

@emackey

This comment has been minimized.

Copy link
Member

commented May 13, 2019

Very cool.

Via ZanQdo on the KhronosDev chat: https://devtalk.blender.org/t/13-may-2019/7076

@andrewpeterprifer

This comment has been minimized.

Copy link

commented Oct 17, 2019

Just ran into this too, any development on this?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.