mising libx.so when trying to run collada2gltf from dev-4 #227

Closed
benbro opened this Issue Feb 14, 2014 · 6 comments

Comments

Projects
None yet
2 participants

benbro commented Feb 14, 2014

I'm building the converter on ubuntu 13.10 and using it on ubuntu 12.04
The converter from master works on ubuntu 12.04 but the converter from dev-4 gives me this error on ubuntu 12.04:

./collada2gltf: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by ./collada2gltf)

Thanks

Contributor

fabrobinet commented Feb 14, 2014

Thank you, I'll try to check that on my side too. I have 12.04 too (not 13.10).

Contributor

fabrobinet commented Feb 14, 2014

Ah sorry... I remember... the fix for linux wan't taken for dev-4, it landed directly in master as the result of a PR in the meantime. the branch named bundle has the fix and should be fine.

Contributor

fabrobinet commented Feb 14, 2014

As as said in a previous issue there is also a fix on OpenCOLLADA that needs to be pushed. I'll try to wrap up dev-4 as it is now make it depend on new OpenCOLLADA version.
I will let you know when all is ready on master - should be safer.

benbro commented Feb 14, 2014

I'll wait for all fixes from the dev branches to go to master.
Thanks

@benbro benbro closed this Feb 14, 2014

Contributor

fabrobinet commented Feb 14, 2014

Merge went smoothly @benbro should be good on master with the fix now (including OpenCOLLADA version, so you need to update submodules too).

benbro commented Feb 14, 2014

Thanks.
I'm really excited about the performance improvements when loading large models with three.js.
Can't wait for compression, transparency and IE11 support :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment