Skip to content
No description, website, or topics provided.
Shell
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
LICENSE.md
README.md
fix-eclipse-ubuntu-15.10-laf.sh
fix-eclipse-ubuntu-16.04-laf.sh

README.md

Eclipse : GTK3 and Ubuntu workarounds

Ubuntu 16.10

Eclipse + GTK3 + Ubuntu 16.10 doesn't work.
Use GTK2.

  1. Install libwebkitgtk-1.0-0 (https://bugs.eclipse.org/bugs/show_bug.cgi?id=456786)
  2. use an eclipse.desktop file with below text to launch eclipse with GTK2

    [Desktop Entry]
    Version=4.6.1
    Name=Eclipse 4.6.1
    Comment=Eclipse IDE 4.6.1
    Exec=env SWT_GTK3=0 GTK2_RC_FILES=<DIR>/.gtkrc-eclipse <DIR>/eclipse-jee-neon/eclipse
    Icon=<DIR>/eclipse-jee-neon/icon.xpm
    Terminal=false
    Type=Application
    Categories=Utility;Application;

    Replace <DIR> with the proper directory.
    You can get the gtkrc-eclipse file from jeeeyul-eclipse-themes.

fix-eclipse-ubuntu-16.04-laf.sh


DONT USE with Eclipse 4.5: Eclipse 4.5 has some issues with GTK3 in Ubuntu 16.04.
Alternatives:

  1. Disable GTK3 with the "SWT_GTK3=0",i.e., fallback to GTK2
  2. Try Eclipse 4.6 along with this script

fix-eclipse-ubuntu-15.10-laf.sh


This script fixes the ugly tooltip in Eclipse using GTK3 when running on Ubuntu with Ambiance Theme. It also saves a laucher script to your desktop and Ubuntu dash search. The fix is visible only if launch using the launcher.

Usage:
<path>/fix-eclipse-ubuntu-15.10-laf.sh <path/to/eclipse>

Limitations:
Currently only works on Ubuntu 15.10 for Ambiance theme.

Please do send me pull requests if you have any update to the scripts like fixes for other Linux OSes, themes, etc.

You can’t perform that action at this time.