Fetch and display required version of Symfony... #141

Merged
merged 4 commits into from Mar 18, 2012

Conversation

Projects
None yet
3 participants
Contributor

Palleas commented Feb 28, 2012

... based on the "require" section of the composer.json (if any), hope it's relevant enough. :)

Contributor

stof commented Feb 28, 2012

you should check the requirement on symfony/framework-bundle too as it is what bundles should generally use (to allow people to use the individual repos if they want)

Contributor

Palleas commented Feb 28, 2012

@stof added, thanks :)

src/Knp/Bundle/KnpBundlesBundle/Resources/views/Bundle/show.html.twig
@@ -12,6 +12,7 @@
<h3>{% trans %}bundles.show.infos.title{% endtrans %}</h3>
<ul>
<li>{% trans %}bundles.show.infos.score{% endtrans %} <span><a href="#bundle-score-details">{{ bundle.score }}</a></span></li>
+ <li>Required Symfony version : {{ bundle.symfonyVersion ? bundle.symfonyVersion : "unknown" }}</li>
@ubermuda

ubermuda Feb 28, 2012

Contributor

missing {% trans %}

@Palleas

Palleas Feb 29, 2012

Contributor

Fixed, sorry.

I'm not sure about where to put the "bundles.show.infos.unknown" key though...

@ubermuda ubermuda merged commit 59c5383 into KnpLabs:master Mar 18, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment