Official Objective-C SDK for integrating Kumulos services with your mobile & mac apps
Objective-C Ruby
Switch branches/tags
Nothing to show
Latest commit 512e0d2 Apr 19, 2017 @cgwyllie cgwyllie committed on GitHub Add language hints to README code snippets

README.md

Kumulos Objective-C SDK Carthage compatible

Kumulos provides tools to build and host backend storage for apps, send push notifications, view audience and behavior analytics, and report on adoption, engagement and performance.

Select an installation method below to get started.

Get Started with CocoaPods

Add the following line to your app's target in your Podfile:

pod 'KumulosSdkObjectiveC', '~> 1.2'

Run pod install to install your dependencies.

After installation, you can now import & initialize the SDK with:

@import KumulosSDK;

Kumulos *k = [[Kumulos alloc] initWithAPIKey:@"YOU_API_KEY" andSecretKey:@"YOUR_SECRET_KEY"];

For more information on integrating the Objective-C SDK with your project, please see the Kumulos Objective-C integration guide.

Get Started with Carthage

Add the following line to your Cartfile:

github "Kumulos/KumulosSdkObjectiveC" ~> 1.2

Run carthage update to install your dependencies then follow the Carthage integration steps to link the framework with your project.

After installation, you can now import & initialize the SDK with:

@import KumulosSDK;

Kumulos *k = [[Kumulos alloc] initWithAPIKey:@"YOU_API_KEY" andSecretKey:@"YOUR_SECRET_KEY"];

For more information on integrating the Objective-C SDK with your project, please see the Kumulos Objective-C integration guide.

Contributing

Pull requests are welcome for any improvements you might wish to make. If it's something big and you're not sure about it yet, we'd be happy to discuss it first. You can either file an issue or drop us a line to support@kumulos.com.

To get started with development, simply clone this repo, run a carthage update and open the workspace to kick things off.

License

This project is licensed under the MIT license with portions licensed under the BSD 2-Clause license. See our LICENSE file and individual source files for more information.

Requirements

  • iOS9+