Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

PHP Warning: explode() expects parameter 2 to be string #6055

Closed
sshcli opened this issue Jul 19, 2018 · 3 comments
Closed

PHP Warning: explode() expects parameter 2 to be string #6055

sshcli opened this issue Jul 19, 2018 · 3 comments
Labels
Milestone

Comments

@sshcli
Copy link
Member

@sshcli sshcli commented Jul 19, 2018

Steps to reproduce the behavior:

  1. Upgrade from 5.1.1 to 5.1.2
  2. Upgrade from 5.1.2 to 5.1.3-dev

Expected behavior
No PHP Warnings in error_log

Actual result
PHP Warning: explode() expects parameter 2 to be string, array given in /home/username/public_html/components/com_kunena/models/search.php on line 131

System information (please complete the following information)
Joomla version: 3.8.10
Kunena version: 5.1.3-DEV
Php version: 7.2.7
Database version: MySQL 5.6.39

@xillibit xillibit added this to the 5.1.3 milestone Jul 19, 2018
@sshcli
Copy link
Member Author

@sshcli sshcli commented Jul 19, 2018

IMO, the cause could be one of these changes:
52b1e2f
965d181

@810
Copy link
Member

@810 810 commented Jul 19, 2018

updating does not use the search model, which search options did you test

810 added a commit that referenced this issue Jul 19, 2018
@810
Copy link
Member

@810 810 commented Jul 19, 2018

Leave a comment

@810 810 closed this Jul 19, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants