Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Attachment preview goes wrong in some cases #5390 #5402

Merged
merged 1 commit into from
Jun 10, 2017

Conversation

xillibit
Copy link
Member

Pull Request for Issue #5390 .

Summary of Changes

Testing Instructions

@xillibit xillibit added this to the 5.0.10 milestone May 28, 2017
@rich20
Copy link
Member

rich20 commented May 28, 2017

The problem is another. If you insert a new image in a message, it will no displayed in the preview. The image can't be displayed, before it is uploaded. But the upload occurs during submit the message.
Therefore you see on edit the previously uploaded images but not the new inserted images.

g4690

@xillibit
Copy link
Member Author

I have tried by adding an new attachment image, i haven't checked by adding an image which isn't an attachment

@rich20
Copy link
Member

rich20 commented May 28, 2017

When you add a image, the image is only registered in the database. Therefore you have no preview. It will then be uploaded if you click on Submit. Afterwards the preview works for this image.

@xillibit
Copy link
Member Author

xillibit commented Jun 9, 2017

In fact it's the reverse, when you submit your message the attachment is saved in database

@rich20
Copy link
Member

rich20 commented Jun 10, 2017

You can test it.

  1. Click on reply
  2. Add a attachment
  3. Click Cancel or Remove Attachment (or do nothing)
  4. Check the database or go in backend to "Tools -> Diagnostics"
    The attachment is now listed as orphaned

@xillibit
Copy link
Member Author

Try now it should works

@rich20
Copy link
Member

rich20 commented Jun 10, 2017

  • Success

@810 810 merged commit 877f1f5 into Kunena:K5.0 Jun 10, 2017
@xillibit xillibit deleted the K5.0_bugs18 branch June 10, 2017 20:32
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants