Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

npm install kurento-client failed because this package used ancient p… #2

Closed
wants to merge 3 commits into from

Conversation

@oisnot
Copy link

commented Nov 28, 2018

npm install kurento-client failed because this package used ancient package dependencies. Updated inherits, ws, bufferutil, utf-8-validate

Øistein Notnæs
npm install kurento-client failed because this package used ancient p…
…ackage dependencies. Updated inherits, ws, bufferutil, utf-8-validate
@jenkinskurento

This comment has been minimized.

Copy link
Contributor

commented Nov 28, 2018

Hi there. Thanks for your PR.

I'm waiting for a Kurento member to verify that this patch is reasonable to test. If it is, they should reply with check out please on its own line. Until that is done, I will not automatically test new commits in this PR, but the usual testing commands by org members will still work. Regular contributors should join the org to skip this step.

@jenkinskurento

This comment has been minimized.

Copy link
Contributor

commented Nov 28, 2018

There were errors, for info, please see...

@alQlagin

This comment has been minimized.

Copy link
Contributor

commented Jan 16, 2019

Any updates?

@alQlagin

This comment has been minimized.

Copy link
Contributor

commented Jan 16, 2019

utf-8-validate was added here 9eda093#diff-b9cfc7f2cdf78a7f4b91a753d10865a2

but there are no usages in code after that time

@VuThuyThuy97

This comment has been minimized.

Copy link

commented Apr 8, 2019

I have same problem.

@sl45sms

This comment has been minimized.

Copy link

commented May 10, 2019

+1

@sl45sms

This comment has been minimized.

Copy link

commented May 10, 2019

as a workaround, with yarn, add
"resolutions": {
"kurento-client/**/utf-8-validate": "5.0.2"
}
on package.json

@j1elo

This comment has been minimized.

Copy link
Member

commented Jul 22, 2019

Fixed in commits 2f9c17b, 4a633fd.

@j1elo j1elo closed this Jul 22, 2019

@j1elo j1elo self-assigned this Jul 22, 2019

@j1elo j1elo added this to In progress in Release 6.11 via automation Jul 22, 2019

@j1elo j1elo moved this from In progress to Done in Release 6.11 Jul 22, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
6 participants
You can’t perform that action at this time.