Skip to content
Fetching contributors…
Cannot retrieve contributors at this time
101 lines (93 sloc) 5.09 KB
usage: pacman {-S --sync} [options] [package(s)]
options:
-b, --dbpath <path> set an alternate database location
-c, --clean remove old packages from cache directory (-cc for all)
-d, --nodeps skip dependency version checks (-dd to skip all checks)
-g, --groups view all members of a package group
(-gg to view all groups and members)
-i, --info view package information (-ii for extended information)
-l, --list <repo> view a list of packages in a repo
-p, --print print the targets instead of performing the operation
-q, --quiet show less information for query and search
-r, --root <path> set an alternate installation root
-s, --search <regex> search remote repositories for matching strings
-u, --sysupgrade upgrade installed packages (-uu enables downgrades)
-v, --verbose be verbose
-w, --downloadonly download packages but do not install/upgrade anything
-y, --refresh download fresh package databases from the server
(-yy to force a refresh even if up to date)
--arch <arch> set an alternate architecture
--asdeps install packages as non-explicitly installed
--asexplicit install packages as explicitly installed
--assume-installed <package=version>
add a virtual package to satisfy dependencies
--cachedir <dir> set an alternate package cache location
--color <when> colourise the output
--config <path> set an alternate configuration file
--confirm always ask for confirmation
--dbonly only modify database entries, not package files
--debug display debug messages
--force force install, overwrite conflicting files
--gpgdir <path> set an alternate home directory for GnuPG
--hookdir <dir> set an alternate hook location
--ignore <pkg> ignore a package upgrade (can be used more than once)
--ignoregroup <grp>
ignore a group upgrade (can be used more than once)
--logfile <path> set an alternate log file
--needed do not reinstall up to date packages
--noconfirm do not ask for any confirmation
--noprogressbar do not show a progress bar when downloading files
--noscriptlet do not execute the install scriptlet if one exists
--print-format <string>
specify how the targets should be printed
usage: pkgbuilder [-h] [-V] [-S] [-F] [--userfetch USER] [-i] [-s] [-u] [-U]
[-X] [-c] [--noclean] [--colors] [-C] [--debug] [--nodebug]
[--depcheck] [-d] [-D] [--novcsupgrade] [--validation] [-v]
[--install] [-w] [--pgpcheck] [--skippgpcheck] [--confirm]
[--noconfirm] [--shallow] [--deep] [--ignore PACKAGE] [-y]
[--notmp] [--build]
[PACKAGE [PACKAGE ...]]
An AUR helper (and library) in Python 3.
positional arguments:
PACKAGE AUR/ABS packages to build
optional arguments:
-h, --help show this help message and exit
-V, --version show version number and quit
operations:
-S, --sync build in /tmp
-F, --fetch fetch package files
--userfetch USER fetch all package files of an user
-i, --info view package information
-s, --search search the AUR for matching strings
-u, --sysupgrade upgrade installed AUR packages
-U, --upgrade move package files to pacman cache and install them
-X, --runtx run transactions from .tx files
options:
-c, --clean clean up work files before and after build
--noclean don't clean up work files before and after build
(default)
--colors use colors in output (default)
-C, --nocolors don't use colors in output
--debug display debug messages
--nodebug don't display debug messages (default)
--depcheck check dependencies (default)
-d, --nodepcheck don't check dependencies (may break makepkg)
-D, --vcsupgrade upgrade all the VCS/date-versioned packages
--novcsupgrade don't upgrade all the VCS/date-versioned packages
(default)
--validation check if packages were installed after build (default)
-v, --novalidation don't check if packages were installed after build
--install install packages after building (default)
-w, --buildonly don't install packages after building
--pgpcheck verify source files with PGP signatures (default)
--skippgpcheck do not verify source files with PGP signatures
--confirm ask for confirmation (default)
--noconfirm do not ask for any confirmation
--shallow use shallow git clones (default)
--deep use deep git clones
--ignore PACKAGE ignore a package upgrade (can be used more than once)
-y, --refresh (dummy)
configuration overrides:
--notmp don't build in /tmp
--build build (instead of fetching)
Also accepts ABS packages.
Something went wrong with that request. Please try again.