Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

RHEL 7 latest kernel breaking LIS integration #296

Closed
chvalean opened this issue Mar 7, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@chvalean
Copy link
Member

commented Mar 7, 2017

RHEL recently published kernel 3.10.0-514.10.2.el7.x86_64.
If we install LIS 4.1.3-1 on top of the new kernel, after reboot the VM will hang and fail to boot.

This has been reported by two users using the v-magine OpenStack deployment in this thread

All LIS modules report unknown symbols at boot time, including storvsc, which fails to load. This leads to dracut-initqueue timeout messages.
A few sample boot messages for reference:

[ 1.304404] hv_storvsc: disagrees about version of symbol vmbus_driver_unregister
[ 1.304406] hv_storvsc: Unknown symbol vmbus_driver_unregister (err -22)
[ 1.304731] hv_storvsc: Unknown symbol __vmbus_driver_register (err -22)
[ 1.304737] hv_storvsc: disagrees about version of symbol vmbus_sendpacket_mpb_desc
[ 1.304738] hv_storvsc: Unknown symbol vmbus_sendpacket_mpb_desc (err -22)
[ 1.304740] hv_storvsc: disagrees about version of symbol vmbus_are_subchannels_present
[ 1.304740] hv_storvsc: Unknown symbol vmbus_are_subchannels_present (err -22)

@vyadavmsft

This comment has been minimized.

Copy link
Collaborator

commented Mar 9, 2017

Fixed now.

@vyadavmsft vyadavmsft closed this Mar 9, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.