Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix empty VST tracks creating noise in playback #3798

Merged
merged 1 commit into from Sep 10, 2017

Conversation

@DomClark
Copy link
Member

@DomClark DomClark commented Sep 8, 2017

Fixes #3308. Clear the buffer in vestigeInstrument::play if no plugin is present.

Copy link
Member

@zonkmachine zonkmachine left a comment

Tested. Fix confirmed!

@PhysSong
Copy link
Member

@PhysSong PhysSong commented Sep 9, 2017

Current the status of Mac builds on Travis is bad. If it fails, it's not your fault.
We can safely ignore the Travis, at least for this pull request.
https://www.traviscistatus.com/incidents/4qylrqvy50gy

@PhysSong
Copy link
Member

@PhysSong PhysSong commented Sep 10, 2017

I restarted Travis builds since the mac build seems to be fixed now. It should be done in a couple of hours.
Edit: It passed just now, after 42 minutes since I restarted the build.

@zonkmachine zonkmachine merged commit cfb7a89 into LMMS:stable-1.2 Sep 10, 2017
1 check passed
1 check passed
continuous-integration/travis-ci/pr The Travis CI build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants
You can’t perform that action at this time.