Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Errors loading zap-desktop after installing (linux-amd64.deb package) #2070

Closed
05nelsonm opened this issue Apr 19, 2019 · 1 comment

Comments

2 participants
@05nelsonm
Copy link

commented Apr 19, 2019

Description

Installed in accordance with instructions by executing:
$ sudo dpkg -i Zap-linux-amd64-v0.4.1-beta.deb
and then to install dependencies:
$ sudo apt-get -f install

When executing $ zap-desktop from terminal, Zap opens, but posts the following to terminal in red:

Unhandled rejection Error: ENOENT: no such file or directory, open '/opt/Zap/resources/app-update.yml'
    at readFile (/opt/Zap/resources/app.asar/dist/webpack:/node_modules/electron-updater/out/AppUpdater.js:625:1)
    at Generator.next (<anonymous>)
From previous event:
    at t.AppImageUpdater.loadUpdateConfig (/opt/Zap/resources/app.asar/dist/webpack:/node_modules/electron-updater/out/AppUpdater.js:620:1)
    at t.Lazy.loadUpdateConfig (/opt/Zap/resources/app.asar/dist/webpack:/node_modules/electron-updater/out/AppUpdater.js:221:1)
    at t.Lazy.creator [as value] (/opt/Zap/resources/app.asar/dist/webpack:/node_modules/electron-updater/node_modules/lazy-val/out/main.js:17:1)
    at value (/opt/Zap/resources/app.asar/dist/webpack:/node_modules/electron-updater/out/AppUpdater.js:503:1)
    at Generator.next (<anonymous>)
    at runCallback (timers.js:694:18)
    at tryOnImmediate (timers.js:665:5)
    at processImmediate (timers.js:647:5)
From previous event:
    at t.AppImageUpdater.getUpdateInfoAndProvider (/opt/Zap/resources/app.asar/dist/webpack:/node_modules/electron-updater/out/AppUpdater.js:499:1)
    at getUpdateInfoAndProvider (/opt/Zap/resources/app.asar/dist/webpack:/node_modules/electron-updater/out/AppUpdater.js:532:1)
    at Generator.next (<anonymous>)
From previous event:
    at t.AppImageUpdater.doCheckForUpdates (/opt/Zap/resources/app.asar/dist/webpack:/node_modules/electron-updater/out/AppUpdater.js:529:1)
    at t.AppImageUpdater.doCheckForUpdates [as checkForUpdates] (/opt/Zap/resources/app.asar/dist/webpack:/node_modules/electron-updater/out/AppUpdater.js:361:1)
    at e.value (/opt/Zap/resources/app.asar/dist/webpack:/electron/updater.js:58:21)
    at e.setInterval (/opt/Zap/resources/app.asar/dist/webpack:/electron/updater.js:59:5)
    at App.trace (/opt/Zap/resources/app.asar/dist/webpack:/electron/main.js:283:13)

Expected Behavior

Should not post errors

Actual Behavior

Posts errors

Possible Fix

Steps to Reproduce

    1. Install zap IAW instructions using the Zap-linux-amd64-v0.4.1-beta.deb package
    1. Install dependencies
    1. Start wallet from terminal

Context

Your Environment

  • Zap version: 0.4.1-beta
  • Operating System and version:
    uname -a output:
    Linux Ubuntu-Desktop 4.18.0-17-generic #18~18.04.1-Ubuntu SMP Fri Mar 15 15:27:12 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
@welcome

This comment has been minimized.

Copy link

commented Apr 19, 2019

👋 Thanks for opening your first issue here! If you're reporting a 🐞 bug, please make sure you include steps to reproduce it.
To help make it easier for us to investigate your issue, please follow the contributing guidelines.

@mrfelton mrfelton self-assigned this Apr 22, 2019

@mrfelton mrfelton added this to the v0.4.2-beta milestone Apr 22, 2019

mrfelton added a commit to mrfelton/zap-desktop that referenced this issue Apr 22, 2019

@mrfelton mrfelton referenced this issue Apr 22, 2019

Merged

fix(electron): handle autoupdate errors #2079

4 of 6 tasks complete

@mrfelton mrfelton modified the milestones: v0.4.2-beta, v0.5.0-beta Apr 23, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.