v0.0.6

@LRFLEW LRFLEW released this Oct 21, 2016 · 1 commit to develop since this release

The long awaited update is here. This update provides a number of changes to the launcher.

  • The launcher is able to download 64-bit builds for all platforms. The version of the game downloaded is tied to the version of the launcher, so the 64-bit launcher downloads 64-bit builds, and vice versa.
  • The Options window has been reworked to only include options that are not easily changed in-game. You should use the in-game options to edit the settings that have been removed from the launcher.
  • Various bug and text fixes.
  • Updated Windows and OS X releases to Qt 5.7

This update is recommended for all users.

Windows Users: The launcher now provides both 32-bit and 64-bit builds of the launcher, which distribute 32-bit and 64-bit builds of the game. There are performance benefits possible with the 64-bit build, so if you're running a 64-bit version of Windows, you should use the 64-bit version of the launcher. If you are unsure if your computer is 64-bit or not, try using the 64-bit installer first. If you can't run the installer (with an error message related to processor architectures), then use the 32-bit version. The 32-bit version of the installer will also provide a warning if you're installing it on a 64-bit version of Windows.

The 64-bit version of the installer is just called OpenRCT2Launcher-win.exe, while the 32-bit version is called OpenRCT2Launcher-win-x86.exe.

Linux Users: This build is not self-contained. You should use your package manager to get all the dependent libraries. The required libraries are zlib, openssl, and qt5 (specifically, the submodules core, gui, widgets, and network). These do not need to be the dev versions. For example, on Debian and Ubuntu, it is sufficient to run:
sudo apt-get install zlib1g libssl1.0.0 libqt5core5a libqt5gui5 libqt5widgets5 libqt5network5

Downloads