Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Added stub ffi gem.

  • Loading branch information...
commit e08107f71f39cc8d2be7cdfec14dc2ee2e9b66fe 1 parent 841266c
@brixen brixen authored
View
BIN  preinstalled-gems/data/cache/ffi-1.0.9.gem
Binary file not shown
View
14 preinstalled-gems/data/gems/ffi-1.0.9/LICENSE
@@ -0,0 +1,14 @@
+Copyright (c) 2008-2010 Ruby-FFI contributors
+All rights reserved.
+
+This code is free software: you can redistribute it and/or modify it under
+the terms of the GNU Lesser General Public License version 3 only, as
+published by the Free Software Foundation.
+
+This code is distributed in the hope that it will be useful, but WITHOUT
+ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License
+version 3 for more details.
+
+You should have received a copy of the GNU Lesser General Public License
+version 3 along with this work. If not, see <http://www.gnu.org/licenses/>.
View
2  preinstalled-gems/data/gems/ffi-1.0.9/README
@@ -0,0 +1,2 @@
+This gem is bundled with Rubinius to satisfy dependencies on ffi gem. Rubinius
+provides FFI natively.
View
30 preinstalled-gems/data/gems/ffi-1.0.9/Rakefile
@@ -0,0 +1,30 @@
+#!/usr/bin/env rake
+# -*- Ruby -*-
+require 'rubygems'
+require 'rake/gempackagetask'
+
+base_spec = Gem::Specification.new do |s|
+ s.name = "ffi"
+
+ s.homepage = "http://rubini.us"
+ s.summary = "Foreign Function Interface for Ruby - Rubinius Stub Gem"
+ s.description = "This gem is bundled with Rubinius to satisfy dependencies on ffi gem. Rubinius provides FFI natively."
+
+ s.version = "1.0.9"
+
+ s.authors = ["Brian Ford"]
+ s.email = "bford@engineyard.com"
+ s.platform = Gem::Platform::RUBY
+ s.files = ["LICENSE", "README", "Rakefile", "lib/ffi.rb"]
+ s.require_paths = "lib"
+ s.rubygems_version = "1.5.2"
+
+ s.date = Time.now
+end
+
+# Rake task to build the default package
+Rake::GemPackageTask.new(base_spec) do |pkg|
+ pkg.need_tar = true
+end
+
+task :default => [:package]
View
1  preinstalled-gems/data/gems/ffi-1.0.9/lib/ffi.rb
@@ -0,0 +1 @@
+# Does nothing. FFI is provided natively in Rubinius.
View
28 preinstalled-gems/data/specifications/ffi-1.0.9.gemspec
@@ -0,0 +1,28 @@
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = "ffi"
+ s.version = "1.0.9"
+
+ if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new(">= 0")
+ end
+ s.authors = ["Brian Ford"]
+ s.date = "2011-08-23"
+ s.description = "This gem is bundled with Rubinius to satisfy dependencies on ffi gem. Rubinius provides FFI natively."
+ s.email = "bford@engineyard.com"
+ s.files = ["LICENSE", "README", "Rakefile", "lib/ffi.rb"]
+ s.homepage = "http://rubini.us"
+ s.require_paths = ["lib"]
+ s.rubygems_version = "1.5.2"
+ s.summary = "Foreign Function Interface for Ruby - Rubinius Stub Gem"
+
+ if s.respond_to? :specification_version
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ else
+ end
+ end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.