Renfos Technologies edited this page Mar 15, 2016 · 3 revisions

Welcome to the Lavalite cms wiki.

System Requirements

Lavalite is designed to run on a machine with PHP 5.5 and MySQL 5.5.

  • PHP >= 5.5.9 with
    • OpenSSL PHP Extension
    • PDO PHP Extension
    • Mbstring PHP Extension
    • Tokenizer PHP Extension
  • Composer installed to load the dependencies of Lavalite.

Installation

It is really easy to install the CMS in 4 steps.

  1. You may install by cloning from github, or via composer.
  • Github:
    • git clone git@github.com:LavaLite/cms.git
    • From a command line open in the folder, run composer install.
  • Composer:
    • composer create-project LavaLite/cms --prefer-dist website
  1. Enter your database details in .env file on root folder.
  2. Run php artisan migrate --seed to setup your database.
  3. You can configure the site in the config folder before production.

####Permissions Lavalite may require one set of permissions to be configured: folders within storage require write access by the web server. For more detals on installation check laravel installation giude http://laravel.com/docs/5.1/installation

Clone this wiki locally
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.
Press h to open a hovercard with more details.