New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support AMD and Node/CommonJS module systems #64

Merged
merged 2 commits into from Apr 26, 2017

Conversation

Projects
None yet
2 participants
@mpschaeuble
Contributor

mpschaeuble commented Apr 25, 2017

If leaflet is used with a module system, a packager like webpack cannot resolve the dependencies if this plugin has no support for it. As a result, the plugin cannot be used as the script loading order cannot be determined.

This pull request adds support for the AMD and Node/CommonJS module systems.

@jfirebaugh

Thanks for the contribution!

Show outdated Hide outdated dist/Leaflet.fullscreen.js Outdated

@jfirebaugh jfirebaugh merged commit 958f2ef into Leaflet:gh-pages Apr 26, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment