Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Installing tobi, errors node v0.6.1 #70

quangv opened this Issue Nov 15, 2011 · 0 comments


None yet
2 participants

quangv commented Nov 15, 2011

The current version being installed with npm npm -d install tobi is 0.1.1, I was having errors with using it.

$> coffee tobi.coffee
The "sys" module is now called "util". It should have a similar interface.

I tried installing the current version, but got the following error:

$> pwd 
     => myproject
$> cd node_modules
$> git clone https://github.com/LearnBoost/tobi.git
$> cd tobi
$> npm -d install

npm ERR! Error: No compatible version found: express@'>=2.3.0- <2.4.0-'
npm ERR! Valid install targets:
npm ERR! ["0.14.0","0.14.1","1.0.0beta","1.0.0beta2","1.0.0rc","1.0.0rc2","1.0.0rc3","1.0.0rc4","1.0.0","1.0.1","1.0.2","1.0.3","1.0.4","1.0.5","1.0.6","1.0.7","2.5.0"]
npm ERR!     at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:424:10)
npm ERR!     at /usr/local/lib/node_modules/npm/lib/cache.js:406:17
npm ERR!     at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:136:7)
npm ERR!     at Object.cb [as oncomplete] (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:36:9)

npm ERR! System Linux 3.0.0-12-generic
npm ERR! command "node" "/usr/local/bin/npm" "-d" "install"
npm ERR! cwd /home/quang/ssh/myproject/node_modules/tobi
npm ERR! node -v v0.6.1
npm ERR! npm -v 1.0.105
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/quang/ssh/myproject/node_modules/tobi/npm-debug.log
npm not ok

Who knows, maybe it's a npm thing...

I thought it was weird npm is telling me npm ERR! Error: No compatible version found: express@'>=2.3.0- <2.4.0-' and then noticed in package.json

  , "devDependencies": {
      "express": "2.3.x"

I tried installing express v2.3.12 but got this error

$> npm -d install express@2.3.12

npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: express@2.3.12
npm ERR! Required: {"node":">= 0.4.1 < 0.5.0"}
npm ERR! Actual:   {"npm":"1.0.105","node":"0.6.1"}

I'm not exactly where this error is coming from, I suspect it has to do with capabilities issues with node 0.6.1, or express 2.4.x
So I'm assuming tobi doesn't support node 0.6.1 ?


Also is this the correct way to use tobi? my test file tobi.coffee

tobi = require 'tobi'
app = require './../server'

browser = tobi.createBrowser app

browser.get '/', (res, $)->
    res.should.have.status 200

And I'm running the tobi test with command coffee tobi.coffee

@tj tj closed this in 488dcbb Nov 15, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment