Spotted by @renodr: As of 2025-07-01, midnight UTC, the Microsoft Update service has expired and is no longer eligible to be enabled on Windows 7 and 8. (If Windows 2000, XP, and Vista could still connect to WU, they would also hit this.)
authorization.xml
From: http://ds.download.windowsupdate.com/v11/2/microsoftupdate/redir/v6-muauth.cab
<?xml version="1.0" encoding="UTF-8"?>
<ProviderAuthorizationInfo
xmlns="http://schemas.microsoft.com/msus/2002/12/SUSProviderAuthorization"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<ServiceID>7971f918-a847-4430-9279-4a52d1efe18d</ServiceID>
<CabVersion>8110</CabVersion>
<IssuedDate>2017-12-01T00:00:00.0000000-00:00</IssuedDate>
<ExpiryDate>2025-07-01T00:00:00.0000000-00:00</ExpiryDate>
<RedirectUrl>http://ds.download.windowsupdate.com/v11/2/microsoftupdate/redir/v6-muredir.cab</RedirectUrl>
<RedirectUrl>http://fe2.update.microsoft.com/v11/2/microsoftupdate/redir/v6-muredir.cab</RedirectUrl>
<OffersWindowsPatches>true</OffersWindowsPatches>
<UIPluginCLSID>3809920F-B9D4-42DA-92E0-E26265E0FB89</UIPluginCLSID>
<IsManaged>false</IsManaged>
<CanRegisterWithAU>true</CanRegisterWithAU>
<ServiceUrl>https://fe2.update.microsoft.com/v6/</ServiceUrl>
<SetupPrefix>mu</SetupPrefix>
<LocalizedProperties>
<Language>en</Language>
<Name>Microsoft Update</Name>
</LocalizedProperties>
</ProviderAuthorizationInfo>
This exhibits in one or multiple of:
- You select to enable Microsoft Update, but it doesn’t get enabled, with no error message
- The Windows Update control panel still shows the blue Microsoft Update promo message, and it may even say “Find out more about free software from (null). Click here for details.”
- You get an error dialog saying “Windows Update cannot currently check for updates, because the service is not running. You may need to restart your computer.”
The Windows Update log file shows error 80248015, “An operation did not complete because the registration of the service has expired.”
If Microsoft intends to continue supporting current Windows Server 2008 R2 ESU (possibly also 10 1507 LTSC) customers, they will likely fix this soon. If not, Legacy Update will need to step in. We may not be able to count on this, because I believe ESU licence holders are supposed to be using WSUS.
Indeed, near the date that the cab indicates it was issued, this happened: https://www.bleepingcomputer.com/news/microsoft/windows-7-update-giving-a-80248015-error-heres-why-and-how-to-fix-it-/. It expired on 2017-12-03 and wasn’t fixed until 2017-12-05!
What we can do
Setting back the clock temporarily works, but won’t for much longer, because the TLS connection will fail if the clock is too far out.
As the authorization cab must be Microsoft-signed, this may mean that we need to start using the Legacy Update proxy server on 7 - 8.1 when the user wants to enable Microsoft Update.
There’s the fairly unlikely possibility we can convince the WU agent that the service is not expired, by looking at what exists under the WU Services registry key + SoftwareDistribution folder on a machine that already successfully registered for MU in the past.
There is the possibility the intranet-signing group policy may allow a cab signed by us to work, but I much prefer that at least for now, we can prove a full chain of trust with all updates and config files being Microsoft-signed.
The best solution will of course still be that Microsoft just issues a new authorization cab that bumps the expiry date by another 8 years. Or push the expiry date out an extremely long way away. That would also be nice.
Spotted by @renodr: As of 2025-07-01, midnight UTC, the Microsoft Update service has expired and is no longer eligible to be enabled on Windows 7 and 8. (If Windows 2000, XP, and Vista could still connect to WU, they would also hit this.)
authorization.xml
From: http://ds.download.windowsupdate.com/v11/2/microsoftupdate/redir/v6-muauth.cab
This exhibits in one or multiple of:
The Windows Update log file shows error 80248015, “An operation did not complete because the registration of the service has expired.”
If Microsoft intends to continue supporting current Windows Server 2008 R2 ESU (possibly also 10 1507 LTSC) customers, they will likely fix this soon. If not, Legacy Update will need to step in. We may not be able to count on this, because I believe ESU licence holders are supposed to be using WSUS.
Indeed, near the date that the cab indicates it was issued, this happened: https://www.bleepingcomputer.com/news/microsoft/windows-7-update-giving-a-80248015-error-heres-why-and-how-to-fix-it-/. It expired on 2017-12-03 and wasn’t fixed until 2017-12-05!
What we can do
Setting back the clock temporarily works, but won’t for much longer, because the TLS connection will fail if the clock is too far out.
As the authorization cab must be Microsoft-signed, this may mean that we need to start using the Legacy Update proxy server on 7 - 8.1 when the user wants to enable Microsoft Update.
There’s the fairly unlikely possibility we can convince the WU agent that the service is not expired, by looking at what exists under the WU Services registry key + SoftwareDistribution folder on a machine that already successfully registered for MU in the past.
There is the possibility the intranet-signing group policy may allow a cab signed by us to work, but I much prefer that at least for now, we can prove a full chain of trust with all updates and config files being Microsoft-signed.
The best solution will of course still be that Microsoft just issues a new authorization cab that bumps the expiry date by another 8 years. Or push the expiry date out an extremely long way away. That would also be nice.