Permalink
Switch branches/tags
Nothing to show
Find file
Fetching contributors…
Cannot retrieve contributors at this time
33 lines (21 sloc) 851 Bytes
Libperl++
This is libperl++. A library for embedding and extending perl in C++.
DEPENDENCIES
The library should work on perl 5.8.1 or higher, though 5.10 is recommended. A
recent C++ compiler is required (GCC 4.4 or higher or (in the near future)
MSVC++ 2010). Also, some Boost headers are required to build it, but there are
no dependencies on Boost runtime libraries.
ISSUES
Building libperl++ on Windows currently doesn't work due to issues in Perl's
linking toolchain. This is being worked on.
INSTALLATION
To install this module, run the following commands:
perl Build.PL
./Build
./Build test
./Build install
For more information, see Install.pod
COPYRIGHT AND LICENCE
Copyright (C) 2007, 2008, 2009, 2010 Leon Timmermans
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.