Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
LibPerl++ is a C++ library that provides a more friendly interface for the the perl API. It makes use of advanced features of C++ to make both embedding and extending perl as easy as possible. This repository also contains to helper libraries that may be split out at a later stage: libtap++ and Library::Build.
C++ Perl C
tree: 53785a3678

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
examples
inc
lib/Perlpp
perl++
t
tap++
.gitignore
Build.PL
MANIFEST
MANIFEST.SKIP
META.yml
README

README

Libperl++

This is libperl++. A library for embedding and extending perl in C++.

DEPENDENCIES
The library should work on perl 5.8.1 or higher, though 5.10 is recommended. A
recent C++ compiler is required (I recommend the most recent version you can
get). Also, some Boost headers are required to build it, but there are no
dependencies on Boost runtime libraries.

INSTALLATION

To install this module, run the following commands:

	perl Build.PL
	./Build
	./Build test
	./Build install

For more information, see doc/Install.pod

COPYRIGHT AND LICENCE

Copyright (C) 2007, 2008, 2009, 2010 Leon Timmermans
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.

Something went wrong with that request. Please try again.