LevelUP package helper for distributing with a LevelDOWN-compatible back-end
JavaScript
Latest commit 551120b Dec 27, 2016 @ralphtheninja ralphtheninja Bumped to 1.2.1
Permalink
Failed to load latest commit information.
.gitignore
.jshintrc
.travis.yml
LICENSE.md
README.md
level-packager.js
package.json
test.js

README.md

level-packager

LevelDB Logo

LevelUP package helper for distributing with a LevelDOWN-compatible back-end

NPM NPM

Build Status dependencies

level-packager exports single function which takes a single argument, a LevelDOWN-API compatible storage back-end for LevelUP. The function returns a constructor function that will bundle LevelUP with the given LevelDOWN replacement. The full API is supported, including all optional arguments, repair(), delete() and copy(). See level, level-hyper or level-lmdb as example use-cases.

Also available is a test.js file that can be used to verify that the user-package works as expected.

Contributing

level-packager is an OPEN Open Source Project. This means that:

Individuals making significant and valuable contributions are given commit-access to the project to contribute as they see fit. This project is more like an open wiki than a standard guarded open source project.

See the contribution guide for more details.

License & Copyright

Copyright (c) 2012-2015 level-packager contributors.

level-packager is licensed under the MIT license. All rights not explicitly granted in the MIT license are reserved. See the included LICENSE.md file for more details.