Bad grid when zooming #305

Closed
martinstingl opened this Issue Feb 29, 2012 · 9 comments

Comments

Projects
None yet
4 participants

Open the file inside that archive with "New drawing exchange" selected and zoom out. There are too many grid points shown, see the screenshot.
When opened with "QCad 1.x file" selected the grid works fine while zooming.
Even if the file is bad condition the grid should be presented correctly.
https://sourceforge.net/projects/martinstingl.u/files/dots.zip

Rallaz was assigned Mar 2, 2012

Contributor

Rallaz commented May 14, 2012

Hi Martin,
I have been very busy with my job and with the new dxf library.
I made a test and seems this bug are solved, you can check if it still exist?
In last version "New drawing exchange" are "Drawing exchange"
and the old "Drawing exchange" are "Old drawing exchange"

Hi,
the error is not gone with a current build. I made a short video:
http://sourceforge.net/projects/martinstingl.u/files/dots.ogv/download
The error occurs in both drawing exchange modes.

Contributor

Rallaz commented May 15, 2012

I can not reproduce the issue.
Check in "edit->aplication preferences" tab "appearance"
if "Automatically scale grid" are check

"Automatically scale grid" was not checked, not it is and I get another wrong behaviour when opening the file dots.dxf:

  1. Current presentation at 10/100 grid distance is OK.
  2. Zooming in to 1/10 distance is OK.
  3. Zooming to a grid distance of 0.1/1 is not possible.

Another bug:

  1. Run LibreCAD with a clean file
  2. Zoom in until the grid distance shows 1E-6/1E-5 and zoom in further.
    Bug: The grid distance steps to 10/100.
Contributor

Rallaz commented May 15, 2012

Please Martin, do not mix bugs, open a new issue because they get lost in the thread.

Original bug:
Seems not a bug. With "Automatically scale grid" not checked grid are drawn in fixed distance, zoom independent,
since "Minimal grid spacing".

The two new bugs:
I need to read the grid related code.

Contributor

Rallaz commented May 15, 2012

Please Martin, do not mix bugs, open a new issue because they get lost in the thread.

Original bug:
Seems not a bug. With "Automatically scale grid" not checked grid are drawn in fixed distance, zoom independent,
since "Minimal grid spacing".

The two new bugs:
I need to read the grid related code.

atorrey commented Jan 19, 2013

Copied from issue 352, which appears like it might be related...

Possibly found issue -

In the Application Preferences, I tried increasing the minimum grid spacing to 10. I left the preview items at zero, and have the Automatic scale and large crosshair boxes checked.

In the Current Drawing Preferences, I selected show grid, orthogonal, and set the X and Y spacing to "auto"

This seemed to produce the desired auto-adjusting behavior....

I didn't find this initially, as the defaults were set to zero, as I mentioned in the first post, and my tendency is not to change defaults without either documentation or a good reason to do so....

Perhaps it might be a good thing to change the default on the grid spacing to 10 or some other non-zero value, this would probably work better for most, and if not, it would be more intuitive to see that it's something that needs changing....

Owner

r-a-v-a-s commented Aug 8, 2015

Does QCad still generate this type of file? If not then I think these issues can be closed.

atorrey commented Aug 10, 2015

The report I made didn't involve Q-Cad, but I think that given the age of the report, it can probably be closed as it isn't getting current complaints....

r-a-v-a-s closed this Sep 7, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment