Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

glibc: fix perl #2225

Merged
merged 1 commit into from Nov 19, 2017

Conversation

@MilhouseVH
Copy link
Contributor

commented Nov 16, 2017

I noticed the following error in the build logs:

/home/neil/projects/LibreELEC.tv/build.LibreELEC-RPi2.arm-9.0-devel/glibc-2.26/configure: line 5542: -V:apiversion: command not found

The relevant code in configure is:

   5541 if test "$PERL" != no &&
   5542    (eval `$PERL -V:apiversion`; test `expr "$apiversion" \< 5` -ne 0); then
   5543   PERL=no
   5544 fi

The value of $PERL is being set from:

which results in $PERL being initially blank, which is != no, and consequently configure tries to execute -V:apiversion as a command, before setting PERL=no.

@CvH: needed by libreelec-8.2 too.

@chewitt chewitt merged commit 8727857 into LibreELEC:master Nov 19, 2017
@chewitt chewitt added BACKPORT DONE and removed BACKPORT REQD labels Nov 19, 2017
@chewitt

This comment has been minimized.

Copy link
Member

commented Nov 19, 2017

backport is in #2224

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.