Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

linux: update to linux-4.15.0 #2275

Closed
wants to merge 39 commits into from

Conversation

@MilhouseVH
Copy link
Contributor

commented Nov 28, 2017

Patches for nvidia drivers.

Most of the out-of-tree WiFi (Realtek, bcm_sta) drivers are currently unbuildable and will need a non-trivial update after timer changes. Example in-tree change: rtl8723bs.


Test build posts

Kernel RPi/RPi2 Generic Build Announce
4.15-rc1 Link Link #1204x Link
4.15-rc2 Link
4.15-rc3 Link Link #1212x Link
4.15-rc4 Link Link #1219x Link
4.15-rc5 Link Link #1229x Link
4.15-rc6 Link Link #0102x Link
4.15-rc7 Link Link #0108x Link
4.15-rc8 Link Link #0115x Link
4.15-rc9 Link Link #0124x Link
4.15.0 Link Link #0129x Link
@MilhouseVH MilhouseVH changed the title Linux4150 linux: update to linux-4.15.0 Nov 28, 2017
@MilhouseVH MilhouseVH force-pushed the MilhouseVH:linux4150 branch 3 times, most recently from 781abd5 to e968fe1 Dec 4, 2017
@CGarces

This comment has been minimized.

Copy link
Contributor

commented Dec 4, 2017

I have write access to rtl8192eu and the jwrdegoede version of rtl8189fs (will send a PR to use that source).

In any case, as I see in the compilation log I need to check this https://patchwork.kernel.org/patch/10059179/

I'll try to made the patch on 6 Nov.

@adamg88

This comment has been minimized.

Copy link
Contributor

commented Dec 4, 2017

jwrdegoede rtl8189fs does not work with 3.x

@CGarces

This comment has been minimized.

Copy link
Contributor

commented Dec 4, 2017

Hi @adamg-xda

The code of jwrdegoede rtl8189fs has been changed recently, maybe you have tested and old version.
The last code is the same version that you are using (from khadas)+ some changes to build correctly on x86 and newer kernels + some changes introduced by jwrdegoede like this one

I have tested with mainline kernels and AmLogic kernel 3.10, only AmLogic 3.14 is missing (will do it tonight)

Can you please test again with the last version (from yesterday)?

@adamg88

This comment has been minimized.

Copy link
Contributor

commented Dec 4, 2017

@CGarces the module compiled without issue it just would not load, I cant recall the exact error, I will try it again later today.

@MilhouseVH MilhouseVH force-pushed the MilhouseVH:linux4150 branch 4 times, most recently from d241655 to c6442a2 Dec 4, 2017
@MilhouseVH

This comment has been minimized.

Copy link
Contributor Author

commented Dec 5, 2017

In any case, as I see in the compilation log I need to check this https://patchwork.kernel.org/patch/10059179/

Yes, currently building Generic with this kernel requires additional build host dependencies as per the message below:

 Makefile:938: *** "Cannot generate ORC metadata for CONFIG_UNWINDER_ORC=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel".  Stop.

However we already build the elfutils package (as target dependency for mesa) so it may just be a case of also building elfutils for host, and adding it as a host dependency for x86_64 linux.

@MilhouseVH MilhouseVH force-pushed the MilhouseVH:linux4150 branch 5 times, most recently from c9b4320 to 2034627 Dec 5, 2017
@MilhouseVH MilhouseVH force-pushed the MilhouseVH:linux4150 branch 8 times, most recently from cb1d39a to f2dfc13 Dec 14, 2017
MilhouseVH and others added 26 commits Feb 2, 2018
@MilhouseVH MilhouseVH force-pushed the MilhouseVH:linux4150 branch from 3aed17d to c63af36 Feb 2, 2018
@MilhouseVH

This comment has been minimized.

Copy link
Contributor Author

commented Feb 5, 2018

Closing, as I'm not maintaining two kernel branches indefinitely.

@MilhouseVH MilhouseVH closed this Feb 5, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.