Messages sent on Desktop not shown in App #44

Open
nomeata opened this Issue Oct 18, 2016 · 5 comments

Projects

None yet

2 participants

@nomeata
nomeata commented Oct 18, 2016 edited

Bug description

Messages that I send on Signal Desktop are not shown on the LibreSignal client.

Steps to reproduce

  • Connect Signal Desktop to my LibreSignal client
  • Chat via Desktop

Actual result: On the phone app, I only see the other person’s messages.
Expected result: On the phone app, I see both my and the other persons’s messages.

NB: If I chat on the phone, I see both messages (mine and theirs) in the Desktop app.

Device info

Device: Jolla
Android version: ? (Dalvik runtime)
Signal version: 3.19

Link to debug log

https://gist.github.com/anonymous/2897107c797639a0e26deb4003d569e2

@mimi89999
Member

Please try with the latest version of LS.

@nomeata
nomeata commented Nov 14, 2016

Now on version 3.21.3, as provided on the Jolla store. No change in behavior.

@mimi89999
Member

Hmm... I am neither using LibreSignal nor Chrome, so I can't really help because the log is not quite verbose...

@nomeata
nomeata commented Nov 18, 2016

Some more debugging shows that whenever this happens, the person I am corresponding with, when using Desktop, cannot send messages at all. Our hypothesis is that LibreSignal does not upload enough prekeys or something else is wrong with the prekeys.

@mimi89999 mimi89999 self-assigned this Nov 22, 2016
@nomeata
nomeata commented Nov 24, 2016

JFTR, With microG and vanilla Signal I do not have this problem.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment