Skip to content
This repository

seq( Lifty.liftySettings : _*) [Error]type error in expression #18

Closed
ferrlin opened this Issue · 9 comments

3 participants

ferrlin Mads Hartmann Jensen ldeck
ferrlin

Nice tool by the way but I can't seem to make it work.

Im using Homebrew in Mac which i used to install sbt (0.11.2)

I followed the instruction on installing lifty to sbt ( ~/.sbt/plugins/build.sbt and ~/.sbt/build.sbt).

But after doing the instruction above, I end up with an error message defined in this issue's title.

I hope you could help me on this one.

Thanks in advance,

Jon

ferrlin

Btw, here's the log that I get:

$... error: not found: value Lifty
seq( Lifty.liftySettings : _*)

Mads Hartmann Jensen
Owner

Please remove the following and try again

  • ~/.ivy2/cache
  • all folders named target in ~/.sbt (recursivly)

Does that help?

ferrlin

The issue still persist.

Mads Hartmann Jensen
Owner

Hm,

Please try the snapshot version as

resolvers += Resolver.url("sbt-plugin-snapshots", new URL("http://scalasbt.artifactoryonline.com/scalasbt/sbt-plugin-snapshots/"))(Resolver.ivyStylePatterns)

addSbtPlugin("org.lifty" % "lifty" % "1.7.5-SNAPSHOT")
ferrlin

the error is no longer showing but

using "lifty create lift project " on sbt shell doesn't work

lifty create lift project
[error] Lifty doesn't know any recipe named lift
[error] lifty create lift project
[error] ^

Mads Hartmann Jensen
Owner

Please run this first

lifty learn lift https://raw.github.com/Lifty/lifty/master/lifty-recipe/lifty.json
ferrlin

Thanks a lot.

It's now working like a gem :)

ferrlin ferrlin closed this
Mads Hartmann Jensen
Owner

Awesome! :) I'll update the installation guide to just use the SNAPSHOT version then - I think the other jar might be corrupt.

ldeck
ldeck commented

better to release a new version and update the install guide to suit.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.