New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

java.util.regex.PatternSyntaxException #5

Closed
rajeshpg opened this Issue Nov 17, 2011 · 10 comments

Comments

Projects
None yet
3 participants
@rajeshpg
Contributor

rajeshpg commented Nov 17, 2011

i am getting this java.util.regex.PatternSyntaxException

env: windowsxp

lifty folder is created.

heres what i was doing and the exception i got.

lifty create lift project
Enter value for liftversion[2.4-M5]:
Enter value for mainpack: demo
Enter value for projectName: liftdemo
Enter value for scalaVersion[2.9.1]:
Enter value for modelpack[demo.model]:
Enter value for libpack[demo.lib]:
Rendering: helloworld.ssp
java.util.regex.PatternSyntaxException: Unexpected internal error near index 1

^
at java.util.regex.Pattern.error(Unknown Source)
at java.util.regex.Pattern.compile(Unknown Source)
at java.util.regex.Pattern.(Unknown Source)
at java.util.regex.Pattern.compile(Unknown Source)
at java.lang.String.split(Unknown Source)
at java.lang.String.split(Unknown Source)
at org.lifty.engine.io.FileUtil$.create$1(FileUtil.scala:75)
at org.lifty.engine.io.FileUtil$.writeToFile(FileUtil.scala:88)
at org.lifty.engine.io.FileUtil$.writeToTempFile(FileUtil.scala:52)
at org.lifty.engine.Scalate$$anonfun$processTemplateInMemory$1$$anonfun$apply$8$$anonfun$app
ly$9.apply(Scalate.scala:105)

@rajeshpg

This comment has been minimized.

Show comment
Hide comment
@rajeshpg

rajeshpg Nov 17, 2011

Contributor

found the issue, but did not fix it yet.

environment: windows xp
issue is in
module: lifty-engine
file: FileUtil.scala
linenumber: 75

issue causing code snippet: File.separator

reason: in windows File.separator will return "" (a backslash) and java.util.regex.Pattern cannot compile the character.

I will try to fix this as soon as possible.

Contributor

rajeshpg commented Nov 17, 2011

found the issue, but did not fix it yet.

environment: windows xp
issue is in
module: lifty-engine
file: FileUtil.scala
linenumber: 75

issue causing code snippet: File.separator

reason: in windows File.separator will return "" (a backslash) and java.util.regex.Pattern cannot compile the character.

I will try to fix this as soon as possible.

@mads-hartmann

This comment has been minimized.

Show comment
Hide comment
@mads-hartmann

mads-hartmann Nov 17, 2011

Member

Great! It would be very awesome if you could take a look at it. Currently I don't have access to a windows machine so I need to partition my HDD and install windows before I can try it out myself.

Member

mads-hartmann commented Nov 17, 2011

Great! It would be very awesome if you could take a look at it. Currently I don't have access to a windows machine so I need to partition my HDD and install windows before I can try it out myself.

@mads-hartmann

This comment has been minimized.

Show comment
Hide comment
@mads-hartmann

mads-hartmann Nov 21, 2011

Member

Hi,

Have you had any luck with finding a solution to this?

Thanks,
Mads

Member

mads-hartmann commented Nov 21, 2011

Hi,

Have you had any luck with finding a solution to this?

Thanks,
Mads

@rajeshpg

This comment has been minimized.

Show comment
Hide comment
@rajeshpg

rajeshpg Nov 21, 2011

Contributor

Hi Mads,
Sorry, I did not have time this weekend.
On Nov 21, 2011 1:50 PM, "Mads Hartmann Jensen" <
reply@reply.github.com>
wrote:

Hi,

Have you had any luck with finding a solution to this?

Thanks,
Mads


Reply to this email directly or view it on GitHub:
#5 (comment)

Contributor

rajeshpg commented Nov 21, 2011

Hi Mads,
Sorry, I did not have time this weekend.
On Nov 21, 2011 1:50 PM, "Mads Hartmann Jensen" <
reply@reply.github.com>
wrote:

Hi,

Have you had any luck with finding a solution to this?

Thanks,
Mads


Reply to this email directly or view it on GitHub:
#5 (comment)

@ghorsey

This comment has been minimized.

Show comment
Hide comment
@ghorsey

ghorsey Nov 24, 2011

I am affected by this same problem on a windows 7 machine.

ghorsey commented Nov 24, 2011

I am affected by this same problem on a windows 7 machine.

@mads-hartmann

This comment has been minimized.

Show comment
Hide comment
@mads-hartmann

mads-hartmann Nov 24, 2011

Member

@ghorsey @rajeshpg I'll see if I can fix it later today, but I don't have a way to test it because my windows partition is still broken. Could I get you guys to test it for me once I've published it?

Member

mads-hartmann commented Nov 24, 2011

@ghorsey @rajeshpg I'll see if I can fix it later today, but I don't have a way to test it because my windows partition is still broken. Could I get you guys to test it for me once I've published it?

@rajeshpg

This comment has been minimized.

Show comment
Hide comment
@rajeshpg

rajeshpg Nov 24, 2011

Contributor

Mads, fixed it few mins before.
I will send a pull request.
On Nov 24, 2011 1:43 PM, "Mads Hartmann Jensen" <
reply@reply.github.com>
wrote:

@ghorsey @rajeshpg I'll see if I can fix it later today, but I don't have
a way to test it because my windows partition is still broken. Could I get
you guys to test it for me once I've published it?


Reply to this email directly or view it on GitHub:
#5 (comment)

Contributor

rajeshpg commented Nov 24, 2011

Mads, fixed it few mins before.
I will send a pull request.
On Nov 24, 2011 1:43 PM, "Mads Hartmann Jensen" <
reply@reply.github.com>
wrote:

@ghorsey @rajeshpg I'll see if I can fix it later today, but I don't have
a way to test it because my windows partition is still broken. Could I get
you guys to test it for me once I've published it?


Reply to this email directly or view it on GitHub:
#5 (comment)

@mads-hartmann

This comment has been minimized.

Show comment
Hide comment
@mads-hartmann

mads-hartmann Nov 24, 2011

Member

@rajeshpg Awesome! Does it work on Windows now then or did other bugs show up?

Member

mads-hartmann commented Nov 24, 2011

@rajeshpg Awesome! Does it work on Windows now then or did other bugs show up?

@rajeshpg rajeshpg referenced this issue Nov 24, 2011

Merged

fix for issue #5 #6

mads-hartmann added a commit that referenced this issue Nov 24, 2011

@mads-hartmann

This comment has been minimized.

Show comment
Hide comment
@mads-hartmann

mads-hartmann Nov 24, 2011

Member

I can confirm that it also work on OS X so probably on Linux as well ;) Will publish version 1.7.3 with the fix now - thanks a lot.

Member

mads-hartmann commented Nov 24, 2011

I can confirm that it also work on OS X so probably on Linux as well ;) Will publish version 1.7.3 with the fix now - thanks a lot.

@rajeshpg

This comment has been minimized.

Show comment
Hide comment
@rajeshpg

rajeshpg Nov 24, 2011

Contributor

thanks a lot Mads :-)

Contributor

rajeshpg commented Nov 24, 2011

thanks a lot Mads :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment