Permalink
Browse files

Release 1.7.0 is not binary compatible in Scala.JS

  • Loading branch information...
sarahgerweck committed Feb 6, 2019
1 parent c7b64f3 commit 9121a6a2b82568884c408e6cb91f84683bb127b5
Showing with 6 additions and 2 deletions.
  1. +2 −0 CHANGELOG.md
  2. +4 −2 build.sbt
@@ -81,6 +81,8 @@ changes to how it's coded or built, see the Git history.

## 1.7

**NOTE** This version breaks binary compatibility under Scala.JS

* Add Scala support for 2.13.0-M5
* Update Scala.js to 0.6.26
* Reduce top-level exports in Scala.js
@@ -58,6 +58,8 @@ lazy val root: Project = (project in file ("."))
skip in Test := true
)

lazy val jsPrevVersions = Set.empty[String]

lazy val core = (crossProject(JSPlatform, JVMPlatform) in file ("core"))
.enablePlugins(BasicSettings, SiteSettingsPlugin)
.dependsOn(testing % "test")
@@ -123,7 +125,7 @@ lazy val core = (crossProject(JSPlatform, JVMPlatform) in file ("core"))
)
.jsSettings(jsOpts)
.jsSettings(
prevVersions := Set("1.6.0")
prevVersions := jsPrevVersions
)

lazy val coreJS = core.js
@@ -156,7 +158,7 @@ lazy val testing = (crossProject(JSPlatform, JVMPlatform) in file ("testing"))
)
.jsSettings(jsOpts)
.jsSettings(
prevVersions := Set("1.6.0", "1.6.1")
prevVersions := jsPrevVersions
)

lazy val testingJS = testing.js

0 comments on commit 9121a6a

Please sign in to comment.