Permalink
Browse files

Updated cmake and restricted dependency to 5.1 lua. Fails with lua 5.2.1

  • Loading branch information...
1 parent 2111407 commit 49df95ea96bf0c222babaa77364cdcef6beb6293 @drahosp drahosp committed Sep 12, 2012
Showing with 3 additions and 4 deletions.
  1. +1 −2 CMakeLists.txt
  2. +2 −2 dist.info
View
3 CMakeLists.txt
@@ -12,7 +12,7 @@ include ( lua )
find_package ( Lua )
# Squish itself
-add_custom_command ( OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/squish
+add_custom_target ( bootstrap ALL
COMMAND ${LUA_EXECUTABLE} squish.lua -q --with-minify --with-uglyfy --with-compile --with-virtual-io
COMMAND ${LUA_EXECUTABLE} squish -q gzip
COMMAND ${LUA_EXECUTABLE} squish -q debug
@@ -21,5 +21,4 @@ add_custom_command ( OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/squish
)
install_lua_executable ( squish ${CMAKE_CURRENT_SOURCE_DIR}/squish )
-
install_data ( README COPYRIGHT CHANGES )
View
4 dist.info
@@ -10,5 +10,5 @@ url = "http://code.matthewwild.co.uk/squish"
maintainer = "Peter Drahoš"
depends = {
- "lua >= 5.1"
-}
+ "lua ~> 5.1"
+}

0 comments on commit 49df95e

Please sign in to comment.