Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 38 lines (26 sloc) 1.661 kb
fccc685 Initial open-source release
MLstate authored
1 # -*- conf -*-
2 # opabsl : <!> dependencies : please beware by hacking this file <!>
3 # bymaps used at compile time SHOULD NOT be linked with the implementation of the primitives
4 # primitives used at runtime time SHOULD NOT be linked with libbsl bymaps
5
6 # mlbsl, jsbsl, cbsl, mlstatebsl
7 <*bsl>: traverse
8
9 # c_wall : guidelines
10 <*.c>: c_wall
11
12 # module used at compile time only : OpabslgenPlugin
13 <opabslgenPlugin.{ml,mli,byte,native}>: use_libbase, use_libqmlcompil, use_libbsl
14
15 # module used at runtime, does not depends on libbsl : ServerLib, OpabslgenMLRuntime, OpabslgenMLRuntime_x
16 <serverLib.{ml,mli,byte,native}>: use_libbase
17
18 # external libs dependencies
19 <opabslgenMLRuntime*.{ml,mli,byte,native}>: use_str, use_ssl, use_ssl_threads, use_cryptokit
20
21 # mlstate libs dependencies
22 <opabslgenMLRuntime*.{ml,mli,byte,native}>: use_libbase, use_ulex, use_libtrx, use_libruntime, use_appruntime, use_oparuntime, use_libnet, use_libtools, use_libsecurity, use_database, use_qmlcpsserver, use_libsession, use_libnattraversal, use_libirc
23
24 # module used both, in case of an interpretor (qmltop)
25 # same as the Plugin
26 <opabslgenLoader.{ml,mli,byte,native}>: use_libbase, use_libqmlcompil, use_libbsl
27
28 # same as the Runtime
29 # external libs dependencies
30 <opabslgenLoader.{ml,mli,byte,native}>: use_str, use_ssl, use_ssl_threads, use_cryptokit
31
32 # mlstate libs dependencies
33 <opabslgenLoader.{ml,mli,byte,native}>: use_libbase, use_ulex, use_libtrx, use_libnet, use_appruntime, use_libtools, use_libsecurity, use_database, use_qmlcpsserver, use_libruntime, use_libsession, use_oparuntime
34
35
36 #ppdebug
37 <opabslgenMLRuntime*.ml>: with_mlstate_debug
Something went wrong with that request. Please try again.