Skip to content
This repository
Browse code

[fix] Makefile: fix install-all and install-qmlflat rules

  • Loading branch information...
commit 33e65507ddbf9fe69d2779fac04c332f320b659d 1 parent 1feec9a
Frederic Ye Aqua-Ye authored

Showing 1 changed file with 3 additions and 3 deletions. Show diff stats Hide diff stats

  1. +3 3 Makefile
6 Makefile
@@ -254,17 +254,17 @@ install-bld:
254 254 # Install an opa wrapper with different stdlib and options (for some backwards-compatibility)
255 255 install-qmlflat: # depends on opabsl_for_compiler, but we don't want to run ocamlbuild twice
256 256 @mkdir -p $(INSTALL_DIR)/bin $(INSTALL_DIR)/share/opa/mlstatebsl
257   - @$(INSTALL) $(BUILD_DIR)/lib/plugins/opabsl/mlstatebsl/opabsl_*.opa $(INSTALL_DIR)/share/opa/mlstatebsl
  257 + @$(INSTALL) $(BUILD_DIR)/lib/opabsl.opp/lib/plugins/opabsl/mlstatebsl/opabsl_*.opa $(INSTALL_DIR)/share/opa/mlstatebsl
258 258 @echo "#!/usr/bin/env bash" > $(INSTALL_DIR)/bin/qmlflat
259 259 @echo "set -e" >> $(INSTALL_DIR)/bin/qmlflat
260 260 @echo "set -u" >> $(INSTALL_DIR)/bin/qmlflat
261 261 @chmod 755 $(INSTALL_DIR)/bin/qmlflat
262   - @echo 'exec opa --parser classic --no-stdlib --no-server --no-cps --no-closure --no-ei --no-constant-sharing --no-undot --separated off --value-restriction disabled --no-warn duplicateL0 --no-warn typer.warncoerce --no-warn unused --no-discard-of-unused-stdlib --no-warn pattern $$(if ! grep -qE "(^| )--no-stdlib( |$$)" <<<"$$*"; then echo $(shell sed "s%^[^# ]\+%$(PREFIX)/share/opa/mlstatebsl/opabsl_&%; t OK; d; :OK" lib/plugins/opabsl/mlstatebsl/bsl-sources); fi) "$$@"' \
  262 + @echo 'exec opa --parser classic --no-stdlib --no-server --no-cps --no-closure --no-ei --no-constant-sharing --no-undot --separated off --value-restriction disabled --no-warn duplicateL0 --no-warn typer.warncoerce --no-warn unused --no-discard-of-unused-stdlib --no-warn pattern "$$@"' \
263 263 >> $(INSTALL_DIR)/bin/qmlflat
264 264
265 265 # installs some dev tools on top of the normal install; these should not change often
266 266 install-all: install install-bld install-qmlflat tools/maxmem
267   - @$(INSTALL) platform_helper.sh $(INSTALL_DIR)/bin/
  267 + @$(INSTALL) tools/platform_helper.sh $(INSTALL_DIR)/bin/
268 268 @$(INSTALL) tools/maxmem $(INSTALL_DIR)/bin/
269 269 @rm tools/maxmem
270 270 @$(INSTALL) tools/plotmem $(INSTALL_DIR)/bin/

0 comments on commit 33e6550

Please sign in to comment.
Something went wrong with that request. Please try again.