Debian + Opa v3949 #96

Open
ghost opened this Issue Nov 28, 2012 · 1 comment

Comments

Projects
None yet
1 participant
@ghost

ghost commented Nov 28, 2012

system: Linux crunchbang 3.2.0-4-486 #1 Debian 3.2.32-1 i686 GNU/Linux

Since 32-bit binaries aren't available I thought I'd try compiling it from
source. I sudo apt-get install ocaml. ocaml 3.12 installed. Ran configure.
Nope, need ocaml 4.00.1. Compiled that from source and ocaml -version reports
The OCaml toplevel, version 4.00.1. sudo apt-get install ocaml-ulex libzip-ocaml-dev libocamlgraph-ocaml-dev as ./configure tells me to. Uh-oh,
still reporting

Checking for ulex... Not found
Checking for camlzip... Not found
Checking for ocamlgraph... Not found

😕

I'm not very familiar with ocaml and ocaml packages but I think the problem
is because Debian is installing ulex/camlzip/ocamlgraph alongside the ocaml
3.12 system, not the source-compiled 4.00.1 system. If you could give me some
pointers I'd be more than happy to update the docs/wiki.

Contributor

cedricss commented Nov 28, 2012

tools/dependencies/installation_helper.sh can help.

Then, configure provides -ocamldir option if libs are installed
elsewhere. For both script, read --help or our wiki for more information.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment