Fix version checking for nodejs 0.10.0 #115

Merged
merged 1 commit into from Mar 16, 2013

Conversation

Projects
None yet
3 participants
Contributor

blutack commented Mar 15, 2013

On Ubuntu 12.04, using nodejs from the recommended PPA.

$ nodejs --version
v0.10.0
$ opa create foo
Your version of node seems to be too old. Please upgrade to a more recent version of node (>= v0.6.0)

Patch should be a bit more robust than the older method for future versions.

Fix version checking for nodejs 0.10.0
Version checking should now be a bit more future proof.
Could possibly do with some error handling in case process.versions.node
goes away in future.

Aqua-Ye added a commit that referenced this pull request Mar 16, 2013

Merge pull request #115 from blutack/patch-1
[contrib] launch_helper: Fix version checking for nodejs 0.10.0

@Aqua-Ye Aqua-Ye merged commit 7b4a07e into MLstate:master Mar 16, 2013

@blutack blutack deleted the blutack:patch-1 branch Mar 16, 2013

cloutiy commented Jun 4, 2015

so what is the fix?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment