Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Supported "gem test fuzzy-string-match" with `rubygems-test`.

Updated version number.
  • Loading branch information...
commit d108b455ccbef88a32bbc4a43f281962e49b4460 1 parent e2814e6
@kiyoka kiyoka authored
Showing with 21 additions and 19 deletions.
  1. +1 −0  .gemtest
  2. +5 −4 Rakefile
  3. +1 −1  VERSION.yml
  4. +14 −14 fuzzy-string-match.gemspec
View
1  .gemtest
@@ -0,0 +1 @@
+
View
9 Rakefile
@@ -19,15 +19,16 @@ begin
gemspec.email = "kiyoka@sumibi.org"
gemspec.homepage = "http://github.com/kiyoka/fuzzy-string-match"
gemspec.authors = ["Kiyoka Nishiyama"]
- gemspec.files = FileList['lib/*.rb',
+ gemspec.files = FileList['.gemtest',
+ 'Rakefile',
+ 'VERSION.yml',
+ 'lib/*.rb',
'test/basic_spec.rb',
'test/mutibyte_spec.rb',
- 'benchmark/*.rb',
'LICENSE.txt',
'README.md'].to_a
gemspec.add_dependency( "rspec" )
- gemspec.add_dependency('RubyInline', '>= 3.8.6')
- gemspec.add_development_dependency( "amatch" )
+ gemspec.add_dependency( 'RubyInline', '>= 3.8.6')
gemspec.required_ruby_version = '>= 1.9.1'
end
rescue LoadError
View
2  VERSION.yml
@@ -1,4 +1,4 @@
---
:major: 0
:minor: 9
-:patch: 1
+:patch: 2
View
28 fuzzy-string-match.gemspec
@@ -4,46 +4,46 @@
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
- s.name = %q{fuzzy-string-match}
- s.version = "0.9.1"
+ s.name = "fuzzy-string-match"
+ s.version = "0.9.2"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Kiyoka Nishiyama"]
- s.date = %q{2011-07-30}
- s.description = %q{calculate Jaro Winkler distance.}
- s.email = %q{kiyoka@sumibi.org}
+ s.date = "2012-02-11"
+ s.description = "calculate Jaro Winkler distance."
+ s.email = "kiyoka@sumibi.org"
s.extra_rdoc_files = [
"LICENSE.txt",
"README.md"
]
s.files = [
+ ".gemtest",
"LICENSE.txt",
"README.md",
- "benchmark/vs_amatch.rb",
+ "Rakefile",
+ "VERSION.yml",
"lib/fuzzystringmatch.rb",
- "test/fuzzystringmatch_spec.rb"
+ "test/basic_spec.rb",
+ "test/mutibyte_spec.rb"
]
- s.homepage = %q{http://github.com/kiyoka/fuzzy-string-match}
+ s.homepage = "http://github.com/kiyoka/fuzzy-string-match"
s.require_paths = ["lib"]
s.required_ruby_version = Gem::Requirement.new(">= 1.9.1")
- s.rubygems_version = %q{1.7.2}
- s.summary = %q{fuzzy string matching library}
+ s.rubygems_version = "1.8.15"
+ s.summary = "fuzzy string matching library"
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rspec>, [">= 0"])
- s.add_development_dependency(%q<amatch>, [">= 0"])
+ s.add_runtime_dependency(%q<rspec>, [">= 0"])
s.add_runtime_dependency(%q<RubyInline>, [">= 3.8.6"])
else
s.add_dependency(%q<rspec>, [">= 0"])
- s.add_dependency(%q<amatch>, [">= 0"])
s.add_dependency(%q<RubyInline>, [">= 3.8.6"])
end
else
s.add_dependency(%q<rspec>, [">= 0"])
- s.add_dependency(%q<amatch>, [">= 0"])
s.add_dependency(%q<RubyInline>, [">= 3.8.6"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.