New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

AdBlockPlus blocking social icons #51

Closed
TheMatjaz opened this Issue Feb 7, 2016 · 7 comments

Comments

Projects
None yet
3 participants
@TheMatjaz
Copy link

TheMatjaz commented Feb 7, 2016

After adding your awesome theme to my website, I noticed that the social icons did not appear when AdBlockPlus was activated - tested on Safari and Firefox.

While doing some modifications to the page, looks like the problem is in the class name. AdBlock hates the word social apparently, since blocks the elements named as social-links, social-links-container and social-link. As soon as I changed the word social to something else, like contact, everything was fine.

Example of the blocked part:

<div class="social-links">
    <div class="social-links-container">
          <a class="social-link GithubLink" href="https://github.com/TheMatjaz" target="_blank" rel="me">
          <!-- here the svg image etc. -->

Possible fix:

<div class="contact-links">
    <div class="contact-links-container">
          <a class="contact-link GithubLink" href="https://github.com/TheMatjaz" target="_blank" rel="me">
          <!-- here the svg image etc. -->

Would be nice to integrate this change in the theme to globally fix the issue.

Thanks again for the awesome work!

@ioanrobciuc

This comment has been minimized.

Copy link
Contributor

ioanrobciuc commented Feb 18, 2016

@TheMatjaz, I have tested on my PC and works very good.

@TheMatjaz

This comment has been minimized.

Copy link

TheMatjaz commented Feb 20, 2016

@robciucioan I'm sorry, I don't understand: are you saying that the fix works well or that AdBlock is not causing any issue?

@ioanrobciuc

This comment has been minimized.

Copy link
Contributor

ioanrobciuc commented Feb 21, 2016

@TheMatjaz, AdBlock does not cause any problem.

@ioanrobciuc ioanrobciuc removed this from the 3.10.0 milestone Feb 22, 2016

@cristianraiber

This comment has been minimized.

Copy link
Collaborator

cristianraiber commented Feb 22, 2016

@robciucioan Should this be closed ?

@ioanrobciuc

This comment has been minimized.

Copy link
Contributor

ioanrobciuc commented Feb 22, 2016

@cristianraiber, I not have problems with social icons when the AdBlock is activated.

@cristianraiber

This comment has been minimized.

Copy link
Collaborator

cristianraiber commented Feb 22, 2016

@robciucioan Let's actually go ahead and change the mark-up. The change seems minor (a few minutes, at most) and should help us avoid possible unwanted future problems.

@ioanrobciuc

This comment has been minimized.

Copy link
Contributor

ioanrobciuc commented Feb 23, 2016

ioanrobciuc pushed a commit that referenced this issue Feb 23, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment