When trying to install wdm on Ruby 1.8.7 then it fails with the following error:
wdm requires Ruby version >= 1.9.2
What requires Ruby 1.9? I think that it should be mentioned on README too. Problem appears when i tried to use guard library on my Ruby 1.8 project, which means that guard is not usable with Ruby 1.8 anymore without polling.
WDM uses some thread-management and string-encoding features only available on ruby >= 1.9.2. I didn't write any special code to handle ruby 1.8 because it is almost deprecated (last bug fix for it was released in June!). It's indeed important to mention this fact on the README file, so thanks for the heads up :).
The reason WDM was developed is because the old Windows-specific library used in Guard was slower than polling! I recommend that you upgrade your project to ruby 1.9.3, but if that's not possible, you can use polling.
Add the minimum required version of ruby to the README