Can't find MailCore.h file #59

Closed
galblank opened this Issue Nov 17, 2012 · 3 comments

Comments

Projects
None yet
3 participants

The build goes well when I build for iOs Simulator or Device but when I try to archive it, it says that it can't find MailCore.h
I have an import <MailCore/MailCore.h> and in the Header Search Path I have like suggested her in the manual ( $(BUILT_PRODUCTS_DIR)/../../include ) but it can't find the header

ok, found a solution for this on my own:
For anyone who will get same errors when trying to archive an iOs app you need to add to the Header Search Path ( both Debug and Release ) the following lines :
"$(BUILT_PRODUCTS_DIR)/../../include"
"$(BUILT_PRODUCTS_DIR)/../include"

Owner

mronge commented Nov 25, 2012

Oddly enough it works for me without the second line. Can anyone else confirm that the second include line is required?

Matt Ronge

On Nov 17, 2012, at 1:51 PM, galblank notifications@github.com wrote:

ok, found a solution for this on my own:
For anyone who will get same errors when trying to archive an iOs app you need to add to the Header Search Path ( both Debug and Release ) the following lines :
"$(BUILT_PRODUCTS_DIR)/../../include"
"$(BUILT_PRODUCTS_DIR)/../include"


Reply to this email directly or view it on GitHub.

mronge closed this Mar 14, 2013

I'm still having this issue in one of my iOS projects, neither of these lines added into my Header Search Path have fixed the problem.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment