libetpan not building #71

Open
vdh opened this Issue Feb 15, 2013 · 3 comments

3 participants

@vdh

Xcode 4.6, MailCore 6a7c75b, blank new Mac Cocoa project with ARC enabled

static libetpan Mac build failed with two issues for libetpan/src/low-level/imap/acl_parser.c and libetpan/src/low-level/imap/acl.c:

    Lexical or Preprocessor Issue
    'config.h' file not found with <angled> include; use "quotes" instead

I can't find any mention anywhere of why this is happening or how to fix this. Libetpan's readme only mentions a libetpan/build-mac/update.sh script, but running that gives a different error:

**Error**: You must have `aclocal' installed to compile Mail.
Download the appropriate package for your distribution,
or get the source tarball at ftp://ftp.gnu.org/pub/gnu/
make: *** No rule to make target `stamp-prepare-target'.  Stop.
make: *** No rule to make target `libetpan-config.h'.  Stop.
cp: ../include/libetpan/: No such file or directory
cp: ../config.h: No such file or directory
cp: ../libetpan-config.h: No such file or directory
@mronge
MailCore member

Two things to check:

1) Make sure you have the Xcode Command Line Tools installed
2) Make sure there are no spaces in the path leading up to the MailCore folder (libetpan will fail)

@vdh

Why is this "spaces in path" requirement not mentioned on the MailCore website, or in any other documentation? Why are libetpan's build scripts so fragile?

@abhinavguptas

Still getting this issue, command line tools are in place and no spaces in path for sure.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment