Stack level too deep with Rake #3

Closed
dblock opened this Issue Mar 22, 2011 · 4 comments

Comments

Projects
None yet
4 participants

dblock commented Mar 22, 2011

rails new EnsureTest
edit Gemfile, add
gem "ensure-encoding", :git => "https://github.com/Manfred/Ensure-encoding.git"
bundle install
rake

Error:

rake aborted!
stack level too deep

Owner

Manfred commented Mar 23, 2011

Sorry, I can't reproduce the problem so I wouldn't know where to start fixing it. I assume this is a problem with your version of Bundler or Rubygems, or maybe the fact that you're running it on Windows. You might be able to around it by using the gem version instead of git. If that doesn't work just copy the files from lib over into your lib directory.

http://redmine.ruby-lang.org/search/index/ruby-19?issues=1&q=stack+level+too+deep

I also get this error.

I don't think i'ts related to running on Windoze.
I'm running Ubuntu 11.04 (Natty) and I get the error when i do rake db:create

Owner

Manfred commented Jun 18, 2014

Closing this because I don't have enough information to actually fix it. Please reopen if you come across it again.

Manfred closed this Jun 18, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment