Permalink
Browse files

Don't use rescue nil to guard against Rubygems load failure.

  • Loading branch information...
1 parent 803bcb9 commit efd6db5a20b461fcc4956998561aa811051188a3 @Manfred committed Oct 18, 2011
Showing with 8 additions and 2 deletions.
  1. +2 −1 test/interaction/scripts/say_hi.rb
  2. +6 −1 test/start.rb
@@ -1,5 +1,6 @@
-require 'rubygems' rescue nil
+require 'rubygems'
require 'active_support'
+require 'yaml'
require 'rest'
$:.unshift File.expand_path('../../../../lib', __FILE__)
View
@@ -1,4 +1,9 @@
-require 'rubygems' rescue nil
+begin
+ require 'rubygems'
+rescue
+ puts "[!] Couldn't require Rubygems, please make sure all required libraries are in the load path"
+end
+
require 'bacon'
require 'facon'

0 comments on commit efd6db5

Please sign in to comment.