Permalink
Browse files

Enable appraisal tests for rails 3.1

  • Loading branch information...
1 parent 1c4bc0c commit cf09da6c79223682334fea443608e5ea270d7ab3 @mjonuschat mjonuschat committed Jan 3, 2012
Showing with 22 additions and 3 deletions.
  1. +7 −0 Appraisals
  2. +8 −3 Rakefile
  3. +7 −0 gemfiles/rails-3.1.gemfile
View
@@ -0,0 +1,7 @@
+appraise 'rails-3.1' do
+ gem 'rails', '~> 3.1.0'
+end
+
+#appraise 'rails-3.2' do
+# gem 'rails', '~> 3.2.0.rc1'
+#end
View
@@ -1,6 +1,6 @@
# encoding: utf-8
-require 'rubygems'
-require 'bundler'
+require 'bundler/setup'
+require 'appraisal'
Bundler::GemHelper.install_tasks
@@ -21,4 +21,9 @@ RSpec::Core::RakeTask.new('spec') do |t|
end
desc "Default: Run specs"
-task :default => :spec
+task :default => [:all]
+
+desc 'Test the plugin under all supported Rails versions.'
+task :all => ["appraisal:install"] do |t|
+ exec('rake appraisal spec')
+end
@@ -0,0 +1,7 @@
+# This file was generated by Appraisal
+
+source :rubygems
+
+gem "rails", "~> 3.1.0"
+
+gemspec :path=>"../"

0 comments on commit cf09da6

Please sign in to comment.