Skip to content
Permalink
Browse files

MENT-27 Adding Azure CI testing

Incomplete - tests are still not run due to error with driver
installation
  • Loading branch information...
rusher authored and lawrinn committed Jul 22, 2019
1 parent 9f043a2 commit 7ac764a7bd8d44f9de421816e00b457bf0ee7b0e
Showing with 321 additions and 21 deletions.
  1. +1 −0 .gitignore
  2. +0 −6 .idea/vcs.xml
  3. +7 −4 .travis.yml
  4. +25 −8 .travis/build/Dockerfile
  5. +3 −2 README.md
  6. +1 −1 appveyor.yml
  7. +284 −0 azure-pipelines.yml
@@ -28,6 +28,7 @@ ipch
*.bak
*.so
*.dylib
.idea/
Makefile
CPackConfig.cmake
CPackSourceConfig.cmake

This file was deleted.

@@ -22,7 +22,6 @@ before_install:
- mkdir tmp
- .travis/gen-ssl.sh mariadb.example.com tmp
- export SSLCERT=$PROJ_PATH/tmp
- export CONNECTOR_C_VERSION=v_2.3.3

matrix:
allow_failures:
@@ -34,6 +33,8 @@ matrix:
env: DB=mysql:5.6
- os: linux
env: DB=mysql:5.7
- os: linux
env: DB=build
include:
- os: linux
env: DB=build
@@ -46,14 +47,16 @@ matrix:
- os: linux
env: DB=mariadb:10.2
- os: linux
compiler: gcc
env: DB=mariadb:10.3
- os: linux
compiler: gcc
env: DB=mariadb:10.4
- os: linux
compiler: clang
env: DB=mariadb:10.3
env: DB=mariadb:10.4
- os: osx
compiler: gcc
env: DB=mariadb:10.3
env: DB=mariadb:10.4
- os: linux
env: DB=mariadb:10.2 PACKET=8M MAXSCALE_VERSION=2.1.8
- os: linux
@@ -1,8 +1,22 @@
FROM debian:jessie
# vim:set ft=dockerfile:
FROM ubuntu:bionic

# add our user and group first to make sure their IDs get assigned consistently, regardless of whatever dependencies get added
RUN groupadd -r mysql && useradd -r -g mysql mysql

# https://bugs.debian.org/830696 (apt uses gpgv by default in newer releases, rather than gpg)
RUN set -ex; \
apt-get update; \
if ! which gpg; then \
apt-get install -y --no-install-recommends gnupg; \
fi; \
# Ubuntu includes "gnupg" (not "gnupg2", but still 2.x), but not dirmngr, and gnupg 2.x requires dirmngr
# so, if we're not running gnupg 1.x, explicitly install dirmngr too
if ! gpg --version | grep -q '^gpg (GnuPG) 1\.'; then \
apt-get install -y --no-install-recommends dirmngr; \
fi; \
rm -rf /var/lib/apt/lists/*

# add gosu for easy step-down from root
ENV GOSU_VERSION 1.10
RUN set -ex; \
@@ -21,8 +35,9 @@ RUN set -ex; \
\
# verify the signature
export GNUPGHOME="$(mktemp -d)"; \
gpg --keyserver ha.pool.sks-keyservers.net --recv-keys B42F6819007F00F88E364FD4036A9C25BF357DD4; \
gpg --batch --keyserver ha.pool.sks-keyservers.net --recv-keys B42F6819007F00F88E364FD4036A9C25BF357DD4; \
gpg --batch --verify /usr/local/bin/gosu.asc /usr/local/bin/gosu; \
command -v gpgconf > /dev/null && gpgconf --kill all || :; \
rm -r "$GNUPGHOME" /usr/local/bin/gosu.asc; \
\
chmod +x /usr/local/bin/gosu; \
@@ -37,27 +52,29 @@ RUN mkdir /docker-entrypoint-initdb.d
# install "apt-transport-https" for Percona's repo (switched to https-only)
RUN apt-get update && apt-get install -y --no-install-recommends \
apt-transport-https ca-certificates \
tzdata \
pwgen \
&& rm -rf /var/lib/apt/lists/*

RUN { \
echo "mariadb-server-10.3" mysql-server/root_password password 'unused'; \
echo "mariadb-server-10.3" mysql-server/root_password_again password 'unused'; \
echo "mariadb-server-10.4" mysql-server/root_password password 'unused'; \
echo "mariadb-server-10.4" mysql-server/root_password_again password 'unused'; \
} | debconf-set-selections

RUN apt-get update -y
RUN apt-get install -y software-properties-common wget
RUN apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0xcbcb082a1bb943db
RUN echo 'deb http://yum.mariadb.org/galera/repo/deb jessie main' > /etc/apt/sources.list.d/galera-test-repo.list
RUN apt-key adv --recv-keys --keyserver ha.pool.sks-keyservers.net F1656F24C74CD1D8
RUN echo 'deb http://yum.mariadb.org/galera/repo/deb bionic main' > /etc/apt/sources.list.d/galera-test-repo.list
RUN apt-get update -y

RUN apt-get install -y curl libdbi-perl rsync socat galera3 libnuma1 libaio1 zlib1g-dev libreadline5 libjemalloc1 libsnappy1 libcrack2
RUN apt-get install -y curl libdbi-perl rsync socat galera3 libnuma1 libaio1 zlib1g-dev libreadline5 libjemalloc1 libsnappy1v5 libcrack2

COPY *.deb /root/
RUN chmod 777 /root/*

RUN dpkg -R --install /root/mysql-common*
RUN dpkg -R --install /root/mariadb-common*
RUN dpkg --install /root/mysql-common*
RUN dpkg --install /root/mariadb-common*
RUN dpkg -R --unpack /root/
RUN apt-get install -f -y

@@ -8,8 +8,9 @@

## Status
[![License (LGPL version 2.1)](https://img.shields.io/badge/license-GNU%20LGPL%20version%202.1-green.svg?style=flat-square)](http://opensource.org/licenses/LGPL-2.1)
[![Travis CI status](https://secure.travis-ci.org/MariaDB/mariadb-connector-odbc.png?branch=master)](https://travis-ci.org/MariaDB/seaver) travis-ci.org (master branch)
[![Appveyor CI status](https://ci.appveyor.com/api/projects/status/1fv21j33a6mpkxq5/branch/master?svg=true)](https://ci.appveyor.com/project/LawrinNovitsky/mariadb-connector-odbc) ci.aapveyor.com(master branch)
[![Linux Build](https://secure.travis-ci.org/MariaDB/mariadb-connector-odbc.png?branch=master)](https://travis-ci.org/MariaDB/mariadb-connector-odbc)
[![Windows status](https://ci.appveyor.com/api/projects/status/1fv21j33a6mpkxq5/branch/master?svg=true)](https://ci.appveyor.com/project/LawrinNovitsky/mariadb-connector-odbc)


This is a GA release of the MariaDB Connector/ODBC.
MariaDB Connector/ODBC is released under version 2.1 of the
@@ -38,7 +38,7 @@ before_build:

after_build:
# download and install MariaDB Server
- set FILE=http://mariadb.mirrors.ovh.net/MariaDB/mariadb-%DB%/winx64-packages/mariadb-%DB%-winx64.msi
- cmd: set FILE=http://ftp.hosteurope.de/mirror/archive.mariadb.org//mariadb-%DB%/winx64-packages/mariadb-%DB%-winx64.msi
- ps: Start-FileDownload $Env:FILE -FileName server.msi -Timeout 900000
- msiexec /i server.msi INSTALLDIR=c:\mariadb-server SERVICENAME=mariadb /qn
# create test database

0 comments on commit 7ac764a

Please sign in to comment.
You can’t perform that action at this time.