Skip to content
Browse files

Replaced the references to db_populate with db_seed

  • Loading branch information...
1 parent c023b95 commit c30ed2e2978dfae270dccba3bb2ae163cea468ea @tobioboye tobioboye committed
Showing with 7 additions and 10 deletions.
  1. +2 −2 DropAndRebuildDb.rst
  2. +1 −1 InstallProdOld.rst
  3. +1 −1 InstallProdStable.rst
  4. +1 −3 InstallationGnuLinux.rst
  5. +1 −2 InstallationMacOsX.rst
  6. +1 −1 InstallationWindows.rst
View
4 DropAndRebuildDb.rst
@@ -21,7 +21,7 @@ This will drop the database, recreate it, and load the latest version of the
schema that was in db/schema.rb. Finally, you can (optionally) populate the
database with some quick and dirty records to get you going::
- $> bundle exec rake db:populate
+ $> bundle exec rake db:seed
-Check out the Ruby scripts in db/populate - these are what rake db:populate is
+Check out the Ruby scripts in db/seed.rb - this is what rake db:seed is
running.
View
2 InstallProdOld.rst
@@ -89,7 +89,7 @@ Create an "instructor" user for the person responsible for the course::
Optionally, load some default data into the database (The database can be reset
using `rake db:reset`) ::
- rake db:populate
+ rake db:seed
Configure the MarkUs application in config/environment.rb.
View
2 InstallProdStable.rst
@@ -115,7 +115,7 @@ Create an "instructor" user for the person responsible for the course::
Optionally, load some default data into the database (The database can be
reset using ``rake db:reset``)::
- bundle exec rake db:populate
+ bundle exec rake db:seed
Configure the MarkUs application in
\<MarkUs-APP-Root\>/config/environments/production.rb (see our MarkUs
View
4 InstallationGnuLinux.rst
@@ -82,7 +82,6 @@ This section assumes, you have gem version >= 1.3.6 (required for rails version
So, the list of gems required for MarkUs is as follows:
* rails
-* db_populate
* i18n
* mongrel_cluster
* routing-filter
@@ -183,7 +182,6 @@ You can also run the following to check your gems::
cgi_multipart_eof_fix (2.5.0)
columnize (0.3.2)
daemons (1.1.0)
- db_populate (0.2.6)
factory_data_preloader (0.5.2)
faker (0.9.4)
fastercsv (1.5.4)
@@ -238,7 +236,7 @@ command)::
$> bundle install --without (postgresql) (sqlite) (mysql)
$> bundle exec rake db:create:all # creates all the databases uncommented in config/database.yml
$> bundle exec rake db:schema:load # loads required relations into database
- $> bundle exec rake db:populate # populates database with some data
+ $> bundle exec rake db:seed # populates database with some data
$> bundle exec rake db:test:prepare
$> bundle exec rake test:units
$> bundle exec rake test:functionals
View
3 InstallationMacOsX.rst
@@ -150,7 +150,6 @@ This section assumes, you have gem version >= 1.3.6 (required for rails version
So, the list of gems required for MarkUs is as follows:
* rails
-* db_populate
* i18n
* mongrel_cluster
* routing-filter
@@ -251,7 +250,7 @@ Enter the following commands: ::
Next, you can load the initial database models for the current environment::
- $> bundle exec rake db:populate
+ $> bundle exec rake db:seed
Now, start the server using::
View
2 InstallationWindows.rst
@@ -135,7 +135,7 @@ If you have a problem executing the above command then it is likely that there i
* I recommend that you restart your computer at this point, especially if you get a error about an invalid Win32 application when trying the next step.
* If you want you can populate MarkUs with sample data:
- `rake db:populate`
+ `rake db:seed`
* Because Markus uses an external password validation program, authenticating
a user externally only works on * nix platforms and not on Windows. To

0 comments on commit c30ed2e

Please sign in to comment.
Something went wrong with that request. Please try again.